summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2002-12-13 13:29:00 +0000
committerMarinus Schraal <foser@gentoo.org>2002-12-13 13:29:00 +0000
commit97956eca360d1048d5bda26cd1dcd6f84f51b679 (patch)
treed7096d3545fb75a823d92fc926b7439eee55d10f
parentFix prelink warnings (diff)
downloadhistorical-97956eca360d1048d5bda26cd1dcd6f84f51b679.tar.gz
historical-97956eca360d1048d5bda26cd1dcd6f84f51b679.tar.bz2
historical-97956eca360d1048d5bda26cd1dcd6f84f51b679.zip
New version
-rw-r--r--net-irc/xchat/ChangeLog7
-rw-r--r--net-irc/xchat/files/digest-xchat-1.9.4-r11
-rw-r--r--net-irc/xchat/files/digest-xchat-1.9.71
-rw-r--r--net-irc/xchat/files/xchat-1.9.7-serverlist-corruption-fix.patch94
-rw-r--r--net-irc/xchat/xchat-1.9.7.ebuild (renamed from net-irc/xchat/xchat-1.9.4-r1.ebuild)65
5 files changed, 125 insertions, 43 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 6bafd5494aa0..4d9d4f304f9e 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/xchat
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.34 2002/12/13 11:00:01 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.35 2002/12/13 13:29:00 foser Exp $
+
+*xchat-1.9.7 (13 Dec 2002)
+
+ 13 Dec 2002; foser <foser@gentoo.org> xchat-1.9.7.ebuild :
+ New version
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/net-irc/xchat/files/digest-xchat-1.9.4-r1 b/net-irc/xchat/files/digest-xchat-1.9.4-r1
deleted file mode 100644
index 7e2dffc2770d..000000000000
--- a/net-irc/xchat/files/digest-xchat-1.9.4-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 ed0820b35e5a9c7c5860108a1555236f xchat-1.9.4.tar.bz2 700920
diff --git a/net-irc/xchat/files/digest-xchat-1.9.7 b/net-irc/xchat/files/digest-xchat-1.9.7
new file mode 100644
index 000000000000..be10fcfa6c32
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-1.9.7
@@ -0,0 +1 @@
+MD5 7a26011f12370559ec3d3ac56934afa2 xchat-1.9.7.tar.bz2 825812
diff --git a/net-irc/xchat/files/xchat-1.9.7-serverlist-corruption-fix.patch b/net-irc/xchat/files/xchat-1.9.7-serverlist-corruption-fix.patch
new file mode 100644
index 000000000000..8fca6bbd52e5
--- /dev/null
+++ b/net-irc/xchat/files/xchat-1.9.7-serverlist-corruption-fix.patch
@@ -0,0 +1,94 @@
+diff -ru --exclude=po --exclude=intl --exclude=Makefile.in xchat-1.9.7/src/fe-gtk/servlistgui.c xchat-1.9.8/src/fe-gtk/servlistgui.c
+--- xchat-1.9.7/src/fe-gtk/servlistgui.c 2002-12-12 15:30:40.000000000 +1100
++++ xchat-1.9.8/src/fe-gtk/servlistgui.c 2002-12-13 19:35:04.000000000 +1100
+@@ -45,6 +45,7 @@
+ static GtkWidget *networks_tree; /* network TreeView */
+ static GtkWidget *connect_button;
+ static GtkWidget *connectnew_button;
++static int ignore_changed = FALSE;
+
+ /* global user info */
+ static GtkWidget *entry_nick1;
+@@ -98,10 +99,12 @@
+ static void
+ servlist_entries_populate (ircnet *net)
+ {
+- void *old = selected_net;
+ static GList *cbitems = NULL;
+ int i;
+
++ /* avoid the "changed" callback */
++ ignore_changed = TRUE;
++
+ gtk_entry_set_text (GTK_ENTRY (entry_nick), net->nick ? net->nick : "");
+ gtk_entry_set_text (GTK_ENTRY (entry_user), net->user ? net->user : "");
+ gtk_entry_set_text (GTK_ENTRY (entry_real), net->real ? net->real : "");
+@@ -121,11 +124,9 @@
+ gtk_combo_set_popdown_strings (GTK_COMBO (combo_encoding), cbitems);
+ }
+
+- /* avoid the "changed" callback */
+- old = selected_net;
+- selected_net = NULL;
+ gtk_entry_set_text (GTK_ENTRY (GTK_COMBO (combo_encoding)->entry), net->encoding ? net->encoding : "System default");
+- selected_net = old;
++
++ ignore_changed = FALSE;
+
+ if (net->flags & FLAG_USE_GLOBAL)
+ {
+@@ -745,8 +746,11 @@
+ if (!selected_net)
+ return;
+
+- free (*str);
+- *str = strdup (GTK_ENTRY (entry)->text);
++ if (!ignore_changed)
++ {
++ free (*str);
++ *str = strdup (GTK_ENTRY (entry)->text);
++ }
+ }
+
+ static GtkWidget *
+@@ -938,9 +942,12 @@
+ if (!selected_net)
+ return;
+
+- if (selected_net->encoding)
+- free (selected_net->encoding);
+- selected_net->encoding = strdup (entry->text);
++ if (!ignore_changed)
++ {
++ if (selected_net->encoding)
++ free (selected_net->encoding);
++ selected_net->encoding = strdup (entry->text);
++ }
+ }
+
+ static GtkWidget *
+@@ -969,7 +976,6 @@
+
+ cb = gtk_combo_new ();
+ gtk_combo_set_popdown_strings (GTK_COMBO (cb), cbitems);
+- /*gtk_entry_set_text (GTK_ENTRY (GTK_COMBO (cb)->entry), _("System default"));*/
+ g_signal_connect (G_OBJECT (GTK_COMBO (cb)->entry), "changed",
+ G_CALLBACK (servlist_combo_cb), NULL);
+ gtk_table_attach (GTK_TABLE (table), cb, 1, 2, 7, 8,
+@@ -1082,14 +1088,14 @@
+ return tree;
+ }
+
+-static void
++/*static void
+ skip_motd (GtkWidget * igad, gpointer serv)
+ {
+ if (GTK_TOGGLE_BUTTON (igad)->active)
+ prefs.skipmotd = TRUE;
+ else
+ prefs.skipmotd = FALSE;
+-}
++}*/
+
+ static void
+ no_servlist (GtkWidget * igad, gpointer serv)
diff --git a/net-irc/xchat/xchat-1.9.4-r1.ebuild b/net-irc/xchat/xchat-1.9.7.ebuild
index bc4324b4dc50..5032608fb18d 100644
--- a/net-irc/xchat/xchat-1.9.4-r1.ebuild
+++ b/net-irc/xchat/xchat-1.9.7.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.9.4-r1.ebuild,v 1.2 2002/12/09 04:33:13 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.9.7.ebuild,v 1.1 2002/12/13 13:29:00 foser Exp $
-IUSE="perl gnome ssl gtk python mmx ipv6 nls kde"
+inherit eutils
+IUSE="perl gnome ssl gtk python mmx ipv6 nls kde"
S=${WORKDIR}/${P}
DESCRIPTION="X-Chat is a graphical IRC client for UNIX operating systems."
SRC_URI="http://www.xchat.org/files/source/1.9/${P}.tar.bz2"
@@ -11,7 +12,7 @@ HOMEPAGE="http://www.xchat.org/"
LICENSE="GPL-2"
SLOT="2"
-KEYWORDS="x86 ppc sparc "
+KEYWORDS="~x86 ~ppc ~sparc"
RDEPEND=">=dev-libs/glib-2.0.4
>=x11-libs/gtk+-2.0.5
@@ -20,23 +21,18 @@ RDEPEND=">=dev-libs/glib-2.0.4
>=gnome-base/libgnome-2.0.1
>=gnome-base/gnome-applets-2.0.0
>=gnome-base/gnome-panel-2.0.1 )
- ssl? ( >=dev-libs/openssl-0.9.6d )"
-
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ python? ( dev-lang/python )"
+
DEPEND="${RDEPEND}
nls? ( >=sys-devel/gettext-0.10.38 )"
src_unpack() {
- unpack ${A}
- patch -d ${S} -p1 < ${FILESDIR}/gentoo-${P}-scrolled-tabs.patch
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-serverlist-corruption-fix.patch
}
-# From the xchat 1.9.3 README_FIRST file:
-# (one of the) REMAINING PROBLEMS:
-# * can't compile with gnome, panel and zvt support *
-# stroke
-
src_compile() {
-
local myopts myflags
if [ ! `use perl` ] ; then
@@ -44,34 +40,33 @@ src_compile() {
&& myopts="${myopts} --enable-gnome --enable-panel" \
|| myopts="${myopts} --enable-gtkfe --disable-gnome --disable-zvt"
- use gnome \
- && CFLAGS="${CFLAGS} -I/usr/include/orbit-2.0" \
- || myopts="${myopts} --disable-gnome"
+ # use gnome \
+ # && CFLAGS="${CFLAGS} -I/usr/include/orbit-2.0" \
+ # || myopts="${myopts} --disable-gnome"
fi
use gtk \
+ && myopts="${myopts} --enable-gtkfe" \
|| myopts="${myopts} --disable-gtkfe"
-
use ssl \
- && myopts="${myopts} --enable-openssl"
-
+ && myopts="${myopts} --enable-openssl" \
+ || myopts="${myopts} --disable-openssl"
use perl \
+ && myopts="${myopts} --enable-perl" \
|| myopts="${myopts} --disable-perl"
-
use python \
+ && myopts="${myopts} --enable-python" \
|| myopts="${myopts} --disable-python"
-
use nls \
- && myopts="${myopts} --enable-hebrew --enable-japanese-conv" \
- || myopts="${myopts} --disable-nls"
-
+ && myopts="${myopts} --enable-nls --enable-hebrew" \
+ || myopts="${myopts} --disable-nls --disable-hebrew"
+ # --enable-japanese-conv is broken
use mmx \
&& myopts="${myopts} --enable-mmx" \
|| myopts="${myopts} --disable-mmx"
-
use ipv6 \
- && myopts="${myopts} --enable-ipv6"
-
+ && myopts="${myopts} --enable-ipv6" \
+ || myopts="${myopts} --disable-ipv6"
[ -n "${DISABLE_XFT}" ] && myopts="${myopts} --disable-xft"
@@ -84,23 +79,11 @@ src_compile() {
src_install() {
# some magic to create a menu entry for xchat 2
- sed -e "s:Exec=xchat:Exec=xchat-2:" -e "s:Name=X-Chat:Name=X-Chat 2:" xchat.desktop > xchat-2.desktop
-
- use kde && insinto ${KDEDIR}/share/applnk/Internet \
- || insinto /usr/share/gnome/apps/Internet
- doins xchat-2.desktop
+ mv xchat.desktop xchat.desktop.old
+ sed -e "s:Exec=xchat:Exec=xchat-2:" -e "s:Name=XChat IRC:Name=XChat 2 IRC:" xchat.desktop.old > xchat.desktop
einstall install || die "Install failed"
- # we prefer our own launcher
- rm ${D}/etc/X11/applnk/Internet/xchat.desktop
- rmdir -p ${D}/etc/X11/applnk/Internet
-
- use python &&
- ( dosym /usr/lib/xchat/plugins/python.so-2 /usr/lib/xchat/plugins/python.so )
- use perl &&
- ( dosym /usr/lib/xchat/plugins/perl.so-2 /usr/lib/xchat/plugins/perl.so )
-
dodoc AUTHORS COPYING ChangeLog README
}