summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-05-10 02:05:07 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-05-10 02:05:07 +0000
commit5ba6cdc4a52fc97207e5e3208501d4e17e7ea9fd (patch)
tree3ef78fd372c8c40c58dd4c11e69fb83098d8b945
parentadded nut-1.3.6 unstable (diff)
downloadhistorical-5ba6cdc4a52fc97207e5e3208501d4e17e7ea9fd.tar.gz
historical-5ba6cdc4a52fc97207e5e3208501d4e17e7ea9fd.tar.bz2
historical-5ba6cdc4a52fc97207e5e3208501d4e17e7ea9fd.zip
added nut-1.3.6 unstable
-rw-r--r--net-misc/nut/Manifest5
-rw-r--r--net-misc/nut/files/digest-nut-1.3.61
-rw-r--r--net-misc/nut/nut-1.3.6.ebuild127
3 files changed, 130 insertions, 3 deletions
diff --git a/net-misc/nut/Manifest b/net-misc/nut/Manifest
index a19bb1a00dfe..4ece19f98a39 100644
--- a/net-misc/nut/Manifest
+++ b/net-misc/nut/Manifest
@@ -1,10 +1,9 @@
MD5 6aab9abab0b73d9a5a7a78e644433734 nut-1.0.0.ebuild 2527
-MD5 df766b9b005fa6c5b646e29469410bb3 nut-1.3.6.ebuild~ 3362
MD5 4f14a96d478cf3c1840ae3985da1f44e nut-1.2.1.ebuild 2924
-MD5 df766b9b005fa6c5b646e29469410bb3 nut-1.3.6.ebuild 3362
+MD5 972c7234a465f5d7076affce954b064b nut-1.3.6.ebuild 3365
MD5 547e8cf9de6cd5bb27e6b655a8473c38 nut-1.2.2.ebuild 3282
MD5 a19daba0d25cc253dac0ae3cfad3d8a1 nut-1.2.1-r1.ebuild 3241
-MD5 e5b7727db2fc43c06a0aaa4500858257 ChangeLog 1988
+MD5 11ed5ce7e811e826813bb27bbeb55cf3 ChangeLog 2227
MD5 53b3c22e90b76d9ed4ac9cbbef393c31 files/digest-nut-1.0.0 61
MD5 4f6c951306e95660e88086bc591f03d0 files/digest-nut-1.2.1 61
MD5 ab96c8181bf3780dae5e3377987b05c2 files/digest-nut-1.2.2 61
diff --git a/net-misc/nut/files/digest-nut-1.3.6 b/net-misc/nut/files/digest-nut-1.3.6
new file mode 100644
index 000000000000..2c193216a043
--- /dev/null
+++ b/net-misc/nut/files/digest-nut-1.3.6
@@ -0,0 +1 @@
+MD5 0de885049ad39208927cdbdca8487578 nut-1.3.6.tar.gz 485880
diff --git a/net-misc/nut/nut-1.3.6.ebuild b/net-misc/nut/nut-1.3.6.ebuild
new file mode 100644
index 000000000000..524e2ad4d3e0
--- /dev/null
+++ b/net-misc/nut/nut-1.3.6.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nut/nut-1.3.6.ebuild,v 1.1 2003/05/10 02:04:45 robbat2 Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Network-UPS Tools"
+SRC_URI="http://www.exploits.org/nut/release/${PV%.*}/${P}.tar.gz"
+HOMEPAGE="http://www.exploits.org/nut/"
+KEYWORDS="~x86 ~sparc"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=""
+RDEPEND=">=sys-apps/baselayout-1.8.2"
+
+
+if [ "`use apache2`" ]; then
+ APACHEBIN="apache2"
+else
+ APACHEBIN="apache"
+fi
+
+APACHE="`which ${APACHEBIN}`"
+if [ -z "${APACHE}" -a -x /usr/sbin/${APACHEBIN} ]; then
+ APACHE=/usr/sbin/${APACHEBIN}
+fi
+
+if [ -n "${APACHE}" ]; then
+ DEPEND="${DEPEND} =sys-libs/zlib-1* =media-libs/libgd-1* =media-libs/libpng-1.2*"
+ RDEPEND="${RDEPEND} net-www/apache"
+fi
+RDEPEND="${RDEPEND} ${DEPEND}"
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
+ cp configure.in configure.in.orig
+ sed -e "s:GD_LIBS.*=.*-L/usr/X11R6/lib \(.*\) -lXpm -lX11:GD_LIBS=\"\1:" \
+ configure.in.orig >configure.in
+ WANT_AUTOCONF_2_5=1 autoconf || die
+}
+
+src_compile() {
+ local myconf
+ [ -n "${APACHE}" ] && myconf="--with-cgi --with-cgipath=/home/httpd/cgi-bin" || myconf="--without-cgi"
+
+ #default is to build all drivers; but the following is common:
+ #--with-drivers=apcsmart,hidups
+ ./configure \
+ --prefix=/usr \
+ --with-user=nut \
+ --with-group=nut \
+ --with-port=3493 \
+ --with-drvpath=/sbin \
+ --sysconfdir=/etc/nut \
+ --mandir=/usr/share/man \
+ --with-pidpath=/var/run \
+ --with-logfacility=LOG_DAEMON \
+ --with-statepath=/var/state/nut \
+ --with-altpidpath=/var/state/nut \
+ --with-linux-hiddev \
+ --host=${CHOST} ${myconf} || die
+
+ cp ${S}/drivers/Makefile ${S}/drivers/Makefile.orig
+ sed -e "s:= bestups:= hidups bestups:" ${S}/drivers/Makefile.orig \
+ > ${S}/drivers/Makefile
+ cp ${S}/man/Makefile ${S}/man/Makefile.orig
+ sed -e "s:= powercom.8:= hidups.8 powercom.8:" \
+ ${S}/man/Makefile.orig > ${S}/man/Makefile
+
+ emake || die
+
+ if [ -n "${APACHE}" ]
+ then
+ emake cgi || die
+ fi
+}
+
+src_install() {
+ # Makefile: user/group nut might not exist until after
+ # pkg_preinst() runs; so use root for now, and fix it
+ # up in pkg_postinst().
+ make DESTDIR=${D} RUNUID=root RUNGID=root install || die
+
+ if [ -n "${APACHE}" ]
+ then
+ make DESTDIR=${D} install-cgi || die
+ fi
+ # see above note...
+ rm -rf ${D}/var/state/nut
+
+ dodoc CHANGES COPYING CREDITS INSTALL NEWS README \
+ UPGRADING docs/{FAQ,*.txt,driver.list}
+ docinto cables ; dodoc docs/cables/*
+ docinto drivers ; dodoc docs/drivers/*
+
+ # clean up /etc/nut/*.sample files
+ cd ${D}/etc/nut
+ for i in *.sample
+ do
+ mv $i ${i/.sample/}
+ done
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/upsd-init upsd
+ newexe ${FILESDIR}/upsmon-init upsmon
+}
+
+pkg_preinst() {
+ if ! groupmod nut ; then
+ groupadd -g 84 nut || die "problem adding group nut"
+ fi
+
+ # usermod returns 2 on user-exists-but-no-flags-given
+ usermod nut &>/dev/null
+ if [ $? != 2 ] ; then
+ useradd -u 84 -g nut -s /bin/false -c "nut" \
+ -d /var/state/nut nut || die "problem adding user nut"
+ fi
+}
+
+pkg_postinst() {
+ install -m0700 -o nut -g nut -d ${ROOT}/var/state/nut
+ chown root.nut ${ROOT}/etc/nut/{upsd.conf,upsd.users,upsmon.conf}
+ chmod 640 ${ROOT}/etc/nut/{upsd.conf,upsd.users,upsmon.conf}
+ ewarn "Dont forget to merge any changes in /etc/init.d/._cfgXXXX_halt.sh"
+}