summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-01-03 16:49:00 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-01-03 16:49:00 +0000
commit5811a78ac5f7369708e2e665d9ac09274ea4eaae (patch)
tree5569c42d14ec8a362b8ed6137723fea55aa8703d
parentzappo (diff)
downloadhistorical-5811a78ac5f7369708e2e665d9ac09274ea4eaae.tar.gz
historical-5811a78ac5f7369708e2e665d9ac09274ea4eaae.tar.bz2
historical-5811a78ac5f7369708e2e665d9ac09274ea4eaae.zip
new openssl, new openssh rev to build against the new openssl (for emerge
update people -- openssh will refuse to work if openssl has been updated), and new dynamic bash.
-rw-r--r--dev-libs/openssl/files/digest-openssl-0.9.6c1
-rw-r--r--dev-libs/openssl/files/openssl-0.9.6c-Makefile.org-gentoo.diff20
-rw-r--r--dev-libs/openssl/openssl-0.9.6c.ebuild42
-rw-r--r--net-misc/openssh/files/digest-openssh-3.0.2_p1-r11
-rw-r--r--net-misc/openssh/openssh-3.0.2_p1-r1.ebuild53
-rw-r--r--net-misc/wget/wget-1.8.ebuild53
-rw-r--r--profiles/package.mask39
-rw-r--r--sys-apps/bash/bash-2.05a.ebuild48
-rw-r--r--sys-apps/bash/files/digest-bash-2.05a1
9 files changed, 185 insertions, 73 deletions
diff --git a/dev-libs/openssl/files/digest-openssl-0.9.6c b/dev-libs/openssl/files/digest-openssl-0.9.6c
new file mode 100644
index 000000000000..657732857075
--- /dev/null
+++ b/dev-libs/openssl/files/digest-openssl-0.9.6c
@@ -0,0 +1 @@
+MD5 6d0a279079fae4f0a5a7af60c89ea178 openssl-0.9.6c.tar.gz 2154496
diff --git a/dev-libs/openssl/files/openssl-0.9.6c-Makefile.org-gentoo.diff b/dev-libs/openssl/files/openssl-0.9.6c-Makefile.org-gentoo.diff
new file mode 100644
index 000000000000..db56f706ade8
--- /dev/null
+++ b/dev-libs/openssl/files/openssl-0.9.6c-Makefile.org-gentoo.diff
@@ -0,0 +1,20 @@
+--- Makefile.org.orig Fri Jul 13 21:15:54 2001
++++ Makefile.org Fri Jul 13 21:17:08 2001
+@@ -55,7 +55,7 @@
+
+ CC= gcc
+ #CFLAG= -DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -m486 -Wall -Wuninitialized -DSHA1_ASM -DMD5_ASM -DRMD160_ASM
+-CFLAG= -DTERMIOS -DL_ENDIAN -fomit-frame-pointer -O3 -m486 -Wall -DSHA1_ASM -DMD5_ASM -DRMD160_ASM
++CFLAG=$(CFLAGS) -DTERMIOS -DL_ENDIAN -fomit-frame-pointer -Wall -DSHA1_ASM -DMD5_ASM -DRMD160_ASM
+ DEPFLAG=
+ PEX_LIBS=
+ EX_LIBS=
+@@ -169,7 +169,7 @@
+ MAKEFILE= Makefile.ssl
+ MAKE= make -f Makefile.ssl
+
+-MANDIR=$(OPENSSLDIR)/man
++MANDIR=$(OPENSSLDIR)/../share/man
+ MAN1=1
+ MAN3=3
+ SHELL=/bin/sh
diff --git a/dev-libs/openssl/openssl-0.9.6c.ebuild b/dev-libs/openssl/openssl-0.9.6c.ebuild
new file mode 100644
index 000000000000..2eefb23aee73
--- /dev/null
+++ b/dev-libs/openssl/openssl-0.9.6c.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.6c.ebuild,v 1.1 2002/01/03 16:49:00 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Toolkit for SSL v2/v3 and TLS v1"
+SRC_URI="http://www.openssl.org/source/${P}.tar.gz"
+HOMEPAGE="http://www.openssl.org/"
+
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND} >=sys-devel/perl-5"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-Makefile.org-gentoo.diff || die
+ cp Configure Configure.orig
+ sed -e "s/-O3/$CFLAGS/" -e "s/-m486//" Configure.orig > Configure
+ # Makefile borkage. The MANDIR is set to ${OPENSSLDIR}/man
+ # which is lame
+ sed -e 's:MANDIR=$(OPENSSLDIR)/man:MANDIR=/usr/share/man:g' Makefile | cat > Makefile
+}
+
+src_compile() {
+ ./config --prefix=/usr --openssldir=/usr/ssl shared threads || die
+ emake all || die
+}
+
+src_install() {
+ dodir /usr/ssl
+ make INSTALL_PREFIX=${D} install || die
+ dodoc CHANGES* FAQ LICENSE NEWS README
+ dodoc doc/*.txt
+ docinto html
+ dodoc doc/*.gif doc/*.html
+ insinto /usr/share/emacs/site-lisp
+ doins doc/c-indentation.el
+}
+
+
+
diff --git a/net-misc/openssh/files/digest-openssh-3.0.2_p1-r1 b/net-misc/openssh/files/digest-openssh-3.0.2_p1-r1
new file mode 100644
index 000000000000..6fdfe0c9a1ec
--- /dev/null
+++ b/net-misc/openssh/files/digest-openssh-3.0.2_p1-r1
@@ -0,0 +1 @@
+MD5 2fa62bf878862cb47a7515c35afe35b6 openssh-3.0.2p1.tar.gz 782336
diff --git a/net-misc/openssh/openssh-3.0.2_p1-r1.ebuild b/net-misc/openssh/openssh-3.0.2_p1-r1.ebuild
new file mode 100644
index 000000000000..7e36a687aa54
--- /dev/null
+++ b/net-misc/openssh/openssh-3.0.2_p1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-3.0.2_p1-r1.ebuild,v 1.1 2002/01/03 16:49:00 drobbins Exp $
+
+# Make it more portable between straight releases
+# and _p? releases.
+PARCH=${P/_/}
+S=${WORKDIR}/${PARCH}
+DESCRIPTION="Port of OpenBSD's free SSH release"
+SRC_URI="ftp://ftp.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/${PARCH}.tar.gz"
+HOMEPAGE="http://www.openssh.com/"
+
+#openssh recognizes when openssl has been slightly upgraded and refuses to run. This new rev
+#will use the new openssl.
+RDEPEND="virtual/glibc pam? ( >=sys-libs/pam-0.73 ) >=dev-libs/openssl-0.9.6c sys-libs/zlib "
+DEPEND="${RDEPEND} sys-devel/perl sys-apps/groff tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+src_compile() {
+
+ local myconf
+ use tcpd || myconf="${myconf} --without-tcp-wrappers"
+ use tcpd && myconf="${myconf} --with-tcp-wrappers"
+ use pam || myconf="${myconf} --without-pam"
+ use pam && myconf="${myconf} --with-pam"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc/ssh \
+ --mandir=/usr/share/man \
+ --libexecdir=/usr/lib/misc \
+ --datadir=/usr/share/openssh \
+ --disable-suid-ssh \
+ --with-ipv4-default \
+ --host=${CHOST} ${myconf} || die "bad configure"
+
+ if [ "`use static`" ]
+ then
+ # statically link to libcrypto -- good for the boot cd
+ perl -pi -e "s|-lcrypto|/usr/lib/libcrypto.a|g" Makefile
+ fi
+
+ make || die " compile problem"
+}
+
+src_install() {
+
+ make install-files DESTDIR=${D} || die
+ dodoc ChangeLog CREDITS OVERVIEW README* TODO sshd_config
+
+ insinto /etc/pam.d ; newins ${FILESDIR}/sshd.pam.rc6 sshd
+ exeinto /etc/init.d ; newexe ${FILESDIR}/sshd.rc6 sshd
+}
diff --git a/net-misc/wget/wget-1.8.ebuild b/net-misc/wget/wget-1.8.ebuild
deleted file mode 100644
index ec4d6547402f..000000000000
--- a/net-misc/wget/wget-1.8.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.8.ebuild,v 1.2 2001/12/17 23:18:51 azarah Exp $
-
-NPVER=20011209
-S=${WORKDIR}/${P}
-DESCRIPTION="Network utility to retrieve files from the WWW"
-SRC_URI="ftp://prep.ai.mit.edu/gnu/wget/${P}.tar.gz
- ftp://gatekeeper.dec.com/pub/GNU/wget/${P}.tar.gz
- http://www.biscom.net/~cade/away/wget-new-percentage/wget-new-percentage-cvs-${NPVER}.tar.gz"
-HOMEPAGE="http://www.cg.tuwien.ac.at/~prikryl/wget.html"
-
-DEPEND="virtual/glibc
- nls? ( sys-devel/gettext )
- ssl? ( >=dev-libs/openssl-0.9.6b )"
-
-RDEPEND="virtual/glibc"
-
-src_unpack() {
- unpack ${P}.tar.gz
- unpack wget-new-percentage-cvs-${NPVER}.tar.gz
- cd ${S}/src
- patch -p0 < ${WORKDIR}/wget-new-percentage/wnp-20011208-2.diff || die
-}
-
-src_compile() {
- local myconf
- use nls || myconf="--disable-nls"
- use ssl && myconf="${myconf} --with-ssl"
- use ssl || myconf="${myconf} --without-ssl --disable-opie --disable-digest"
- [ -z "$DEBUG" ] && myconf="${myconf} --disable-debug"
- use ssl && CFLAGS="${CFLAGS} -I/usr/include/openssl"
- ./configure --prefix=/usr --sysconfdir=/etc/wget \
- --infodir=/usr/share/info --mandir=usr/share/man $myconf || die
- if use static; then
- make LDFLAGS="--static" || die
- else
- make || die
- fi
-}
-
-src_install() {
- if use build || use bootcd; then
- insinto /usr
- dobin ${S}/src/wget
- return
- fi
- make prefix=${D}/usr sysconfdir=${D}/etc/wget \
- mandir=${D}/usr/share/man infodir=${D}/usr/share/info install || die
- dodoc AUTHORS COPYING ChangeLog MACHINES MAILING-LIST NEWS README TODO
- dodoc doc/sample.wgetrc
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index 58f7420e482b..e47eaf6c62a8 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -136,7 +136,6 @@ sys-kernel/linux-sources-vanilla
#>=sys-devel/gcc-2.96
# incompatible
->=sys-apps/bash-2.05
>=app-text/pspell-0.12
>=app-text/aspell-0.33
>=sys-libs/readline-4.2
@@ -262,22 +261,22 @@ dev-libs/libiconv
>=app-editors/xemacs-21.4.5
# Fails with new Java scheme (karltk)
-net-www/cocoon-1.8
-net-www/cocoon-1.8.2
-net-www/tomcat-3.2.2
-net-www/tomcat-3.2.1
-net-www/tomcat-4.0.1
-net-www/jakarta-3.1-r2
-media-libs/pdflib-4.0.1
-dev-java/ant-1.3
-dev-java/ant-1.4
-dev-java/fesi-1
-dev-java/jaxp-1.1
-dev-java/jaxp-1.0.1
-dev-java/jndi-1.2.1-r1
-dev-java/jsse-1.0.2
-dev-java/mysql-jdbc-1.2.3-r1
-dev-lang/swig/swig-1.3_alpha5-r2
+=net-www/cocoon-1.8
+=net-www/cocoon-1.8.2
+=net-www/tomcat-3.2.2
+=net-www/tomcat-3.2.1
+=net-www/tomcat-4.0.1
+=net-www/jakarta-3.1-r2
+=media-libs/pdflib-4.0.1
+=dev-java/ant-1.3
+=dev-java/ant-1.4
+=dev-java/fesi-1
+=dev-java/jaxp-1.1
+=dev-java/jaxp-1.0.1
+=dev-java/jndi-1.2.1-r1
+=dev-java/jsse-1.0.2
+=dev-java/mysql-jdbc-1.2.3-r1
+=dev-lang/swig/swig-1.3_alpha5-r2
# Moved all of gkrellm stuff to x11-misc
app-admin/gkrellm-gnome
@@ -290,6 +289,6 @@ media-sound/gkrellmms
net-misc/gkrellmwireless
#Should be tested
-dev-lang/python-2.2
-net-mail/teapop-0.3.3
-dev-lang/php-4.1.1
+>=dev-lang/python-2.2
+=net-mail/teapop-0.3.3
+=dev-lang/php-4.1.1
diff --git a/sys-apps/bash/bash-2.05a.ebuild b/sys-apps/bash/bash-2.05a.ebuild
new file mode 100644
index 000000000000..e3f5b7f401d2
--- /dev/null
+++ b/sys-apps/bash/bash-2.05a.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/bash/bash-2.05a.ebuild,v 1.1 2002/01/03 16:49:00 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The standard GNU Bourne again shell"
+SRC_URI="ftp://ftp.gnu.org/gnu/bash/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
+
+#A recent baselayout is needed since bash is dynamic.
+DEPEND=">=sys-libs/ncurses-5.2-r2 readline? ( >=sys-libs/readline-4.1-r2 ) >=sys-apps/baselayout-1.8"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ local myconf
+ [ "`use readline`" ] && myconf="--with-installed-readline"
+ [ -z "`use nls`" ] && myconf="${myconf} --disable-nls"
+ ./configure --prefix=/ \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} \
+ --disable-profiling \
+ --with-curses \
+ ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
+ dodir /bin
+ mv ${D}/usr/bin/bash ${D}/bin
+ dosym bash /bin/sh
+
+ if [ -z "`use build`" ]
+ then
+ doman doc/*.1
+ if [ -z "`use readline`" ]
+ then
+ doman doc/*.3
+ fi
+ dodoc README NEWS AUTHORS CHANGES COMPAT COPYING Y2K
+ dodoc doc/FAQ doc/INTRO
+ else
+ rm -rf ${D}/usr
+ fi
+}
diff --git a/sys-apps/bash/files/digest-bash-2.05a b/sys-apps/bash/files/digest-bash-2.05a
new file mode 100644
index 000000000000..c0db45f3fbe6
--- /dev/null
+++ b/sys-apps/bash/files/digest-bash-2.05a
@@ -0,0 +1 @@
+MD5 eeabc3f624861c4a8a687f7701db3d06 bash-2.05a.tar.gz 1810432