summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-12-10 21:36:33 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-12-10 21:36:33 +0000
commit4976905c7b2af4a32fdc5bf383094cdd012a63ab (patch)
tree79131a84991e417644c894eee25c2b4f7edd8b15
parentPerl installation fixes at last (diff)
downloadhistorical-4976905c7b2af4a32fdc5bf383094cdd012a63ab.tar.gz
historical-4976905c7b2af4a32fdc5bf383094cdd012a63ab.tar.bz2
historical-4976905c7b2af4a32fdc5bf383094cdd012a63ab.zip
bump
-rw-r--r--net-im/naim/ChangeLog11
-rw-r--r--net-im/naim/files/digest-naim-0.11.51
-rw-r--r--net-im/naim/naim-0.11.5.ebuild57
-rw-r--r--net-im/naim/naim-0.11.5_rc3.ebuild4
4 files changed, 69 insertions, 4 deletions
diff --git a/net-im/naim/ChangeLog b/net-im/naim/ChangeLog
index 60a7c198c42d..d0ca032bc1b4 100644
--- a/net-im/naim/ChangeLog
+++ b/net-im/naim/ChangeLog
@@ -1,10 +1,17 @@
# ChangeLog for net-im/naim
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/naim/ChangeLog,v 1.9 2002/12/10 06:18:27 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/naim/ChangeLog,v 1.10 2002/12/10 21:36:33 lostlogic Exp $
+
+*naim-0.11.5 (10 Dec 2002)
+
+ 10 Dec 2002; Brandon Low <lostlogic@gentoo.org> naim-0.11.5.ebuild :
+ Final realease, check the site changelog for more info. The
+ autocomplete is really neat, check it out. I've been running this
+ series for a few weeks, I see no reason to leave it unstable for long.
*naim-0.11.5_rc3 (10 Dec 2002)
- 10 Dec 2002; Brandon Low <lostlogic@gentoo.org> naim-0.11.5_rc1.ebuild :
+ 10 Dec 2002; Brandon Low <lostlogic@gentoo.org> naim-0.11.5_rc3.ebuild :
Looks like this should be the last _rc release before final. Has some
new features this time like better window resize. Check his
changelogs for more info.
diff --git a/net-im/naim/files/digest-naim-0.11.5 b/net-im/naim/files/digest-naim-0.11.5
new file mode 100644
index 000000000000..cd90fdc33511
--- /dev/null
+++ b/net-im/naim/files/digest-naim-0.11.5
@@ -0,0 +1 @@
+MD5 9405a77b2965889a9e74e26466edc119 naim-0.11.5.tar.gz 370579
diff --git a/net-im/naim/naim-0.11.5.ebuild b/net-im/naim/naim-0.11.5.ebuild
new file mode 100644
index 000000000000..13ba9b75920d
--- /dev/null
+++ b/net-im/naim/naim-0.11.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/naim/naim-0.11.5.ebuild,v 1.1 2002/12/10 21:36:33 lostlogic Exp $
+
+VA="`echo ${PV}|sed -e 's:^\([0-9]*\)\..*$:\1:'`"
+VB="`echo ${PV}|sed -e 's:^[0-9]*\.\([0-9]*\)\..*$:\1:'`"
+FOLDER="naim-0.11.5"
+SNAP=""
+SRC_URI="http://128.113.139.111/~n/.${PN}_archive/${VA}/${VB}/${FOLDER}${SNAP}.tar.gz"
+DESCRIPTION="An ncurses AOL Instant Messenger."
+HOMEPAGE="http://site.rpi-acm.org/info/naim/"
+#P="`echo ${P}|sed -e 's:_.*$::'`"
+P="${P/_/}"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ virtual/glibc"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ einfo "${P}"
+
+ local myconf
+ myconf="--with-gnu-ld --enable-detach"
+ use pic && myconf="${myconf} --with-pic"
+ use static && myconf="${myconf} --enable-static=yes"
+
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ dobin src/naim
+
+ doman naim.1
+
+ dodoc AUTHORS BUGS ChangeLog FAQ NEWS README doc/*
+
+ insinto /usr/share/${P}
+ newins contrib/README.aimconvert README.aimconvert
+ newins contrib/aimconvert.tcl aimconvert.tcl
+ newins contrib/extractbuddy.sh extractbuddy.sh
+ newins contrib/sendim.sh sendim.sh
+ newins src/cmplhlp2.sh cmplhlp2.sh
+ newins src/cmplhelp.sh cmplhelp.sh
+ newins src/cmplsample.sh cmplsample.sh
+ newins src/genkeys.sh genkeys.sh
+
+ insinto /usr/include/${PN}
+ newins include/modutil.h modutil.h
+ newins include/naim.h naim.h
+ newins include/config.h config.h
+}
diff --git a/net-im/naim/naim-0.11.5_rc3.ebuild b/net-im/naim/naim-0.11.5_rc3.ebuild
index f95088ca0e37..5bb983754079 100644
--- a/net-im/naim/naim-0.11.5_rc3.ebuild
+++ b/net-im/naim/naim-0.11.5_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/naim/naim-0.11.5_rc3.ebuild,v 1.1 2002/12/10 06:18:27 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/naim/naim-0.11.5_rc3.ebuild,v 1.2 2002/12/10 21:36:33 lostlogic Exp $
VA="`echo ${PV}|sed -e 's:^\([0-9]*\)\..*$:\1:'`"
VB="`echo ${PV}|sed -e 's:^[0-9]*\.\([0-9]*\)\..*$:\1:'`"
@@ -25,7 +25,7 @@ src_compile() {
einfo "${P}"
local myconf
- myconf="--with-gnu-ld --enable-detach" # --enable-debug"
+ myconf="--with-gnu-ld --enable-detach --enable-debug"
use pic && myconf="${myconf} --with-pic"
use static && myconf="${myconf} --enable-static=yes"