summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2005-06-11 11:28:20 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2005-06-11 11:28:20 +0000
commit2926b1a62b5046578352cc19753d27d4722099fb (patch)
tree0cf63aefc80e0ec45d5a646969cba093371d01f4
parentAdded sys-apps/lm_sensors:sensord (diff)
downloadhistorical-2926b1a62b5046578352cc19753d27d4722099fb.tar.gz
historical-2926b1a62b5046578352cc19753d27d4722099fb.tar.bz2
historical-2926b1a62b5046578352cc19753d27d4722099fb.zip
Version bump, fixing bug #76357, bug #84673, bug #89077 and bug #92946.
Package-Manager: portage-2.0.51.22-r1
-rw-r--r--sys-apps/lm_sensors/ChangeLog11
-rw-r--r--sys-apps/lm_sensors/files/digest-lm_sensors-2.9.11
-rw-r--r--sys-apps/lm_sensors/files/lm_sensors-2.9.1-lm_sensors-init.d105
-rw-r--r--sys-apps/lm_sensors/files/lm_sensors-2.9.1-sensord-conf.d7
-rw-r--r--sys-apps/lm_sensors/files/lm_sensors-2.9.1-sensord-init.d33
-rw-r--r--sys-apps/lm_sensors/files/lm_sensors-2.9.1-sensors-detect-gentoo.patch132
-rw-r--r--sys-apps/lm_sensors/lm_sensors-2.9.1.ebuild122
7 files changed, 410 insertions, 1 deletions
diff --git a/sys-apps/lm_sensors/ChangeLog b/sys-apps/lm_sensors/ChangeLog
index 4cb767ce4065..d2b026c6f681 100644
--- a/sys-apps/lm_sensors/ChangeLog
+++ b/sys-apps/lm_sensors/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-apps/lm_sensors
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/ChangeLog,v 1.25 2005/05/10 09:15:45 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/ChangeLog,v 1.26 2005/06/11 11:28:20 brix Exp $
+
+*lm_sensors-2.9.1 (11 Jun 2005)
+
+ 11 Jun 2005; <brix@gentoo.org> +files/lm_sensors-2.9.1-lm_sensors-init.d,
+ +files/lm_sensors-2.9.1-sensord-conf.d,
+ +files/lm_sensors-2.9.1-sensord-init.d,
+ +files/lm_sensors-2.9.1-sensors-detect-gentoo.patch,
+ +lm_sensors-2.9.1.ebuild:
+ Version bump, fixing bug #76357, bug #84673, bug #89077 and bug #92946.
10 May 2005; David Holm <dholm@gentoo.org> lm_sensors-2.9.0.ebuild:
Added to ~ppc.
diff --git a/sys-apps/lm_sensors/files/digest-lm_sensors-2.9.1 b/sys-apps/lm_sensors/files/digest-lm_sensors-2.9.1
new file mode 100644
index 000000000000..9b9f92a218ca
--- /dev/null
+++ b/sys-apps/lm_sensors/files/digest-lm_sensors-2.9.1
@@ -0,0 +1 @@
+MD5 f5af615e39441d95471bdb72a3f01709 lm_sensors-2.9.1.tar.gz 870765
diff --git a/sys-apps/lm_sensors/files/lm_sensors-2.9.1-lm_sensors-init.d b/sys-apps/lm_sensors/files/lm_sensors-2.9.1-lm_sensors-init.d
new file mode 100644
index 000000000000..5adadecf56e9
--- /dev/null
+++ b/sys-apps/lm_sensors/files/lm_sensors-2.9.1-lm_sensors-init.d
@@ -0,0 +1,105 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/files/lm_sensors-2.9.1-lm_sensors-init.d,v 1.1 2005/06/11 11:28:20 brix Exp $
+
+checkconfig() {
+ if [ ! -f /etc/conf.d/lm_sensors ]; then
+ eerror "/etc/conf.d/lm_sensors does not exist, try running sensors-detect"
+ return 1
+ fi
+
+ if [ "${LOADMODULES}" = "yes" -a -f /proc/modules ]; then
+ if [ -z "${MODULE_0}" ]; then
+ eerror "MODULE_0 is not set in /etc/conf.d/lm_sensors, try running sensors-detect"
+ return 1
+ fi
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ if [ "${LOADMODULES}" = "yes" -a -f /proc/modules ]; then
+ einfo "Loading lm_sensors modules..."
+
+ mount | grep sysfs &> /dev/null
+ if [ ${?} == 0 ]; then
+ if ! ( [ -e /sys/i2c ] || [ -e /sys/bus/i2c ] ); then
+ ebegin " Loading i2c-core"
+ modprobe i2c-core &> /dev/null
+ if [ ${?} != 0 ]; then
+ eerror " Could not load i2c-core!"
+ eend 1
+ fi
+ ( [ -e /sys/i2c ] || [ -e /sys/bus/i2c ] ) || return 1
+ eend 0
+ fi
+ elif ! [ -e /proc/sys/dev/sensors ]; then
+ ebegin " Loading i2c-proc"
+ modprobe i2c-proc &> /dev/null
+ if [ ${?} != 0 ]; then
+ eerror " Could not load i2c-proc!"
+ eend 1
+ fi
+ [ -e /proc/sys/dev/sensors ] || return 1
+ eend 0
+ fi
+
+ i=0
+ while true; do
+ module=`eval echo '$'MODULE_${i}`
+ module_args=`eval echo '$'MODULE_${i}_ARGS`
+ if [ -z "${module}" ]; then
+ break
+ fi
+ ebegin " Loading ${module}"
+ modprobe ${module} ${module_args} &> /dev/null
+ eend $?
+ i=$((i+1))
+ done
+ fi
+
+ if [ "${INITSENSORS}" = "yes" ]; then
+ if ! [ -f /etc/sensors.conf ]; then
+ eerror "/etc/sensors.conf does not exist!"
+ return 1
+ fi
+
+ ebegin "Initializing sensors"
+ /usr/bin/sensors -s &> /dev/null
+ eend ${?}
+ fi
+}
+
+stop() {
+ checkconfig || return 1
+
+ if [ "${LOADMODULES}" = "yes" -a -f /proc/modules ]; then
+ einfo "Unloading lm_sensors modules..."
+
+ # find the highest possible MODULE_ number
+ i=0
+ while true; do
+ module=`eval echo '$'MODULE_${i}`
+ if [ -z "${module}" ] ; then
+ break
+ fi
+ i=$((i+1))
+ done
+
+ while [ ${i} -gt 0 ]; do
+ i=$((i-1))
+ module=`eval echo '$'MODULE_${i}`
+ ebegin " Unloading ${module}"
+ rmmod ${module} &> /dev/null
+ eend $?
+ done
+
+ if [ -e /proc/sys/dev/sensors ] ; then
+ ebegin " Unloading i2c-proc"
+ rmmod i2c-proc &> /dev/null
+ eend $?
+ fi
+ fi
+}
diff --git a/sys-apps/lm_sensors/files/lm_sensors-2.9.1-sensord-conf.d b/sys-apps/lm_sensors/files/lm_sensors-2.9.1-sensord-conf.d
new file mode 100644
index 000000000000..89672f74d38d
--- /dev/null
+++ b/sys-apps/lm_sensors/files/lm_sensors-2.9.1-sensord-conf.d
@@ -0,0 +1,7 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/files/lm_sensors-2.9.1-sensord-conf.d,v 1.1 2005/06/11 11:28:20 brix Exp $
+
+# Extra options to pass to the sensord daemon,
+# see sensord(8) for more information
+SENSORD_OPTIONS=""
diff --git a/sys-apps/lm_sensors/files/lm_sensors-2.9.1-sensord-init.d b/sys-apps/lm_sensors/files/lm_sensors-2.9.1-sensord-init.d
new file mode 100644
index 000000000000..b5795e9e982a
--- /dev/null
+++ b/sys-apps/lm_sensors/files/lm_sensors-2.9.1-sensord-init.d
@@ -0,0 +1,33 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/files/lm_sensors-2.9.1-sensord-init.d,v 1.1 2005/06/11 11:28:20 brix Exp $
+
+CONFIG=/etc/sensors.conf
+
+depend() {
+ need logger
+ use lm_sensors
+}
+
+checkconfig() {
+ if [ ! -f ${CONFIG} ]; then
+ eerror "Configuration file ${CONFIG} not found"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting sensord"
+ start-stop-daemon --start --quiet --exec /usr/sbin/sensord \
+ -- --config-file ${CONFIG} ${SENSORD_OPTIONS}
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping sensord"
+ start-stop-daemon --stop --quiet --pidfile /var/run/sensord.pid
+ eend ${?}
+}
diff --git a/sys-apps/lm_sensors/files/lm_sensors-2.9.1-sensors-detect-gentoo.patch b/sys-apps/lm_sensors/files/lm_sensors-2.9.1-sensors-detect-gentoo.patch
new file mode 100644
index 000000000000..90c1226d6acb
--- /dev/null
+++ b/sys-apps/lm_sensors/files/lm_sensors-2.9.1-sensors-detect-gentoo.patch
@@ -0,0 +1,132 @@
+diff -urp lm_sensors-2.9.1/prog/detect/sensors-detect lm_sensors-2.9.1-sensors-detect-gentoo/prog/detect/sensors-detect
+--- lm_sensors-2.9.1/prog/detect/sensors-detect 2005-03-28 01:10:52.000000000 +0200
++++ lm_sensors-2.9.1-sensors-detect-gentoo/prog/detect/sensors-detect 2005-06-05 14:10:01.000000000 +0200
+@@ -26,6 +26,14 @@
+ # each be put in a separate file, using modules and packages. That is beyond
+ # me.
+
++# Changelog
++# 02/Mar/2003, Rudo Thomas <thomr9am@ss1000.ms.mff.cuni.cz>
++# * a few small changes in config file output to reflect Gentoo Linux layout
++# - /etc/sysconfig -> /etc/conf.d
++# - /etc/rc.d/init.d -> /etc/init.d
++# - added a warning to the generated config file
++# - small change when asking about writing the new config file
++
+ require 5.004;
+
+ use strict;
+@@ -5143,39 +5151,44 @@ sub main
+ my $use_isa = not <STDIN> =~ /\s*[Ss]/;
+
+ my ($modprobes,$configfile) = generate_modprobes $use_isa;
++ print "\nIf you want to load the modules at startup, generate a config file\n",
++ "below and make sure lm_sensors gets started; e.g\n",
++ "\$ rc-update add lm_sensors default.\n";
+ print "\nTo make the sensors modules behave correctly, add these lines to\n",
+- "$modules_conf:\n\n";
++ "/etc/modules.conf:\n\n";
+ print "#----cut here----\n";
+ print $configfile;
+- print "#----cut here----\n";
+- print "\nTo load everything that is needed, add this to some /etc/rc* ",
+- "file:\n\n";
+- print "#----cut here----\n";
+- print $modprobes;
+- print "# sleep 2 # optional\n",
+- "/usr/local/bin/sensors -s # recommended\n";
+- print "#----cut here----\n";
++ print "#----end cut here----\n";
+ print "\nWARNING! If you have some things built into your kernel, the list above\n",
+ "will contain too many modules. Skip the appropriate ones! You really should\n",
+ "try these commands right now to make sure everything is working properly.\n",
+ "Monitoring programs won't work until it's done.\n";
+-
+- my $have_sysconfig = -d '/etc/sysconfig';
+- print "\nDo you want to generate /etc/sysconfig/lm_sensors? (".
+- ($have_sysconfig?"YES/no":"yes/NO")."): ";
+- if ($> != 0) {
+- print "\nAs you are not root, we shall skip this step.\n";
+- } else {
+- $_ = <STDIN>;
+- if (($have_sysconfig and not m/^\s*[Nn]/) or m/^\s*[Yy]/) {
+- unless ($have_sysconfig) {
+- mkdir '/etc/sysconfig', 0777
+- or die "Sorry, can't create /etc/sysconfig ($!)?!?";
+- }
+- open(local *SYSCONFIG, ">/etc/sysconfig/lm_sensors")
+- or die "Sorry, can't create /etc/sysconfig/lm_sensors ($!)?!?";
+- print SYSCONFIG <<'EOT';
+-# /etc/sysconfig/sensors - Defines modules loaded by /etc/rc.d/init.d/lm_sensors
++
++ print "To load everything that is needed, execute the commands above...";
++
++ print "\n\n#----cut here----\n";
++ print $modprobes;
++ print "# sleep 2 # optional\n",
++ "/usr/bin/sensors -s # recommended\n";
++
++ my $have_config = -f '/etc/conf.d/lm_sensors';
++ print "\nDo you want to ".($have_config?"overwrite":"generate").
++ " /etc/conf.d/lm_sensors? Enter s to specify other file name?\n",
++ " (".($have_config?"yes/NO":"YES/no")."/s): ";
++ my $reply = <STDIN>;
++
++ if (($have_config and $reply =~ /^\s*[Yy]/) or
++ (not $have_config and not $reply =~ /^\s*[Nn]/) or
++ $reply =~ /^\s*[Ss]/) {
++ my $filename = "/etc/conf.d/lm_sensors";
++ if ($reply =~ /^\s*[Ss]/) {
++ print "Specify the file to store the configuration to: ";
++ $filename = <STDIN>;
++ }
++ open(SYSCONFIG, ">".$filename)
++ or die "Sorry, can't create $filename ($!).";
++ print SYSCONFIG <<'EOT';
++# /etc/conf.d/sensors - Defines modules loaded by /etc/init.d/lm_sensors
+ # Copyright (c) 1998 - 2001 Frodo Looijaard <frodol@dds.nl>
+ #
+ # This program is free software; you can redistribute it and/or modify
+@@ -5196,18 +5209,27 @@ sub main
+ # See also the lm_sensors homepage at:
+ # http://www2.lm-sensors.nu/~lm78/index.html
+ #
+-# This file is used by /etc/rc.d/init.d/lm_sensors and defines the modules to
+-# be loaded/unloaded. This file is sourced into /etc/rc.d/init.d/lm_sensors.
++# This file is used by /etc/init.d/lm_sensors and defines the modules to
++# be loaded/unloaded. This file is sourced into /etc/init.d/lm_sensors.
+ #
+ # The format of this file is a shell script that simply defines the modules
+ # in order as normal variables with the special names:
+ # MODULE_0, MODULE_1, MODULE_2, etc.
+ #
++# Please note that the numbers in MODULE_X must start at 0 and increase in
++# steps of 1. Any number that is missing will make the init script skip the
++# rest of the modules. Use MODULE_X_ARGS for arguments.
++#
+ # List the modules that are to be loaded for your system
+ #
+ EOT
+ print SYSCONFIG
+- "# Generated by sensors-detect on " . scalar localtime() . "\n";
++ "# Generated by sensors-detect on " . scalar localtime() . "\n\n";
++ print SYSCONFIG
++ "# Load modules at startup\n".
++ "LOADMODULES=yes\n\n".
++ "# Initialize sensors at startup\n".
++ "INITSENSORS=yes\n\n";
+ my @modules = grep /^modprobe /, split "\n", $modprobes;
+ my $i = 0;
+ my $sysconfig = "";
+@@ -5217,9 +5239,7 @@ EOT
+ $i++;
+ }
+ print SYSCONFIG $sysconfig;
+- print "Copy prog/init/lm_sensors.init to /etc/rc.d/init.d/lm_sensors\n";
+- print "for initialization at boot time.\n";
+- }
++ print "Done.\n";
+ }
+ }
+
+Only in lm_sensors-2.9.1-sensors-detect-gentoo/prog/detect: sensors-detect.orig
diff --git a/sys-apps/lm_sensors/lm_sensors-2.9.1.ebuild b/sys-apps/lm_sensors/lm_sensors-2.9.1.ebuild
new file mode 100644
index 000000000000..38f1df93203e
--- /dev/null
+++ b/sys-apps/lm_sensors/lm_sensors-2.9.1.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/lm_sensors-2.9.1.ebuild,v 1.1 2005/06/11 11:28:20 brix Exp $
+
+inherit eutils flag-o-matic linux-info toolchain-funcs multilib
+
+DESCRIPTION="Linux System Hardware Monitoring user-space utilities"
+
+HOMEPAGE="http://secure.netroedge.com/~lm78/"
+SRC_URI="http://secure.netroedge.com/~lm78/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+IUSE="sensord"
+
+DEPEND="sys-apps/sed"
+RDEPEND="dev-lang/perl
+ sensord? ( net-analyzer/rrdtool )"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ if kernel_is 2 4; then
+ if ! has_version =sys-apps/lm_sensors-modules-${PV}; then
+ eerror
+ eerror "${P} needs sys-apps/lm_sensors-modules-${PV} to be installed"
+ eerror "for kernel 2.4.x"
+ eerror
+ die "sys-apps/lm_sensors-modules-${PV} not installed"
+ fi
+ else
+ if ! (linux_chkconfig_present I2C_SENSOR); then
+ eerror
+ eerror "${P} requires CONFIG_I2C_SENSOR to be enabled for non-2.4.x kernels."
+ eerror
+ die "CONFIG_I2C_SENSOR not detected"
+ fi
+ if ! (linux_chkconfig_present I2C_CHARDEV); then
+ eerror
+ eerror "${P} requires CONFIG_I2C_CHARDEV to be enabled for non-2.4.x kernels."
+ eerror
+ die "CONFIG_I2C_CHARDEV not detected"
+ fi
+ if ! (linux_chkconfig_present I2C); then
+ eerror
+ eerror "${P} requires CONFIG_I2C to be enabled for non-2.4.x kernels."
+ eerror
+ die "CONFIG_I2C not detected"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-sensors-detect-gentoo.patch
+
+ if use sensord; then
+ sed -i -e 's:^# \(PROG_EXTRA\):\1:' ${S}/Makefile
+ fi
+}
+
+src_compile() {
+ einfo
+ einfo "You may safely ignore any errors from compilation"
+ einfo "that contain \"No such file or directory\" references."
+ einfo
+
+ filter-flags -fstack-protector
+
+ emake CC=$(tc-getCC) LINUX=${KV_DIR} I2C_HEADERS=${KV_DIR}/include user \
+ || die "emake user failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} PREFIX=/usr MANDIR=/usr/share/man LIBDIR=/usr/$(get_libdir) \
+ KERNELINCLUDEFILES="" user_install || die "emake user_install failed"
+
+ newinitd ${FILESDIR}/${P}-lm_sensors-init.d lm_sensors
+
+ if use sensord; then
+ newconfd ${FILESDIR}/${P}-sensord-conf.d sensord
+ newinitd ${FILESDIR}/${P}-sensord-init.d sensord
+ fi
+
+ dodoc BACKGROUND BUGS CHANGES CONTRIBUTORS INSTALL QUICKSTART \
+ README* TODO
+
+ dodoc doc/cvs doc/donations doc/fancontrol.txt doc/fan-divisors doc/FAQ \
+ doc/progs doc/temperature-sensors doc/vid
+
+ dohtml doc/lm_sensors-FAQ.html doc/useful_addresses.html
+
+ docinto busses
+ dodoc doc/busses/*
+
+ docinto chips
+ dodoc doc/chips/*
+
+ docinto developers
+ dodoc doc/developers/applications doc/developers/design \
+ doc/developers/new_drivers doc/developers/proc \
+ doc/developers/sysctl doc/developers/sysfs-interface
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Next you need to run:"
+ einfo " /usr/sbin/sensors-detect"
+ einfo "to detect the I2C hardware of your system and create the file:"
+ einfo " /etc/conf.d/lm_sensors"
+ einfo
+ einfo "Be warned, the probing of hardware in your system performed by"
+ einfo "sensors-detect could freeze your system. Also make sure you read"
+ einfo "the documentation before running lm_sensors on IBM ThinkPads."
+ einfo
+ einfo "Please see the lm_sensors documentation and website for more information."
+ einfo
+}