summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-08-21 21:55:57 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-08-21 21:55:57 +0000
commit1e9da524852bd4da2c2cb11ecc7d964e2848c966 (patch)
tree697ced7703f440a29cc00ee43734c34c20a74306
parentMinor fixes in dev-ml (diff)
downloadhistorical-1e9da524852bd4da2c2cb11ecc7d964e2848c966.tar.gz
historical-1e9da524852bd4da2c2cb11ecc7d964e2848c966.tar.bz2
historical-1e9da524852bd4da2c2cb11ecc7d964e2848c966.zip
Adapt to findlib eclass, fix IUSE missing.
-rw-r--r--dev-ml/camomile/Manifest4
-rw-r--r--dev-ml/ounit/ChangeLog5
-rw-r--r--dev-ml/ounit/Manifest4
-rw-r--r--dev-ml/ounit/ounit-1.0.0.ebuild17
4 files changed, 15 insertions, 15 deletions
diff --git a/dev-ml/camomile/Manifest b/dev-ml/camomile/Manifest
index 7022376f37a6..ab2c52397977 100644
--- a/dev-ml/camomile/Manifest
+++ b/dev-ml/camomile/Manifest
@@ -1,4 +1,4 @@
-MD5 c2ed50050a3a49d81507086367c0c054 ChangeLog 484
-MD5 a2ddec2554d6f58c2dbc3e5ddff77e07 camomile-0.5.3.ebuild 829
+MD5 ee0bb658e96003dae03f4070f476ee5e camomile-0.5.3.ebuild 642
MD5 8b350f19c06fcabf1053b0421b7c3f5a metadata.xml 155
+MD5 a23a87345adebd0c0965288422cc2a8d ChangeLog 599
MD5 f5acf743fc3456d4b1d4840defd8baa8 files/digest-camomile-0.5.3 68
diff --git a/dev-ml/ounit/ChangeLog b/dev-ml/ounit/ChangeLog
index 4e6953f8e8db..6f573fecb2a9 100644
--- a/dev-ml/ounit/ChangeLog
+++ b/dev-ml/ounit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/ounit
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ChangeLog,v 1.1 2004/08/18 12:17:33 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ChangeLog,v 1.2 2004/08/21 21:55:57 mattam Exp $
+
+ 21 Aug 2004; Matthieu Sozeau <mattam@gentoo.org> ounit-1.0.0.ebuild:
+ Adapt to findlib eclass.
*ounit-1.0.0 (18 Aug 2004)
diff --git a/dev-ml/ounit/Manifest b/dev-ml/ounit/Manifest
index 9ac214f2178a..765bb7680dd4 100644
--- a/dev-ml/ounit/Manifest
+++ b/dev-ml/ounit/Manifest
@@ -1,4 +1,4 @@
-MD5 3ebb2bc6a46a0e663371e4ccec432d8b ChangeLog 444
MD5 8b350f19c06fcabf1053b0421b7c3f5a metadata.xml 155
-MD5 60902ec98b9e40ef59f6c2b543d64137 ounit-1.0.0.ebuild 821
+MD5 2bd836fad6e3c307a24603e738628f9c ChangeLog 543
+MD5 187b2082d09c659f26d6f510d233ebca ounit-1.0.0.ebuild 641
MD5 02270b9f85472c60819e083e602cb39a files/digest-ounit-1.0.0 61
diff --git a/dev-ml/ounit/ounit-1.0.0.ebuild b/dev-ml/ounit/ounit-1.0.0.ebuild
index edf1942f8965..c76cda20b74a 100644
--- a/dev-ml/ounit/ounit-1.0.0.ebuild
+++ b/dev-ml/ounit/ounit-1.0.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ounit-1.0.0.ebuild,v 1.2 2004/08/18 17:48:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ounit-1.0.0.ebuild,v 1.3 2004/08/21 21:55:57 mattam Exp $
+
+inherit findlib
DESCRIPTION="Unit testing framework for OCaml"
HOMEPAGE="http://home.wanadoo.nl/maas/ocaml/"
@@ -8,21 +10,16 @@ SRC_URI="http://home.wanadoo.nl/maas/ocaml/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~x86 ~ppc"
-DEPEND="dev-lang/ocaml
- dev-ml/findlib"
+DEPEND="dev-lang/ocaml"
+IUSE=""
src_compile() {
emake all allopt || die "emake failed"
}
src_install() {
- # which directory does the lib go into?
- destdir=`ocamlfind printconf destdir`
- # install
- mkdir -p ${D}${destdir} || die
- make \
- OCAMLFIND_DESTDIR=${D}${destdir} \
- OCAMLFIND_LDCONF=dummy install || die
+ findlib_src_install
+
# typo
mv LICENCE LICENSE
# install documentation