summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2005-11-13 00:19:20 +0000
committerTorsten Veller <tove@gentoo.org>2005-11-13 00:19:20 +0000
commit1d841b8cb1b6a72ebf6624a836d1874192c8a8fe (patch)
tree1867b24398e4e7e096d37dce35a0d3764af13737
parentAdded ~sparc keyword wrt bug #105447. (diff)
downloadhistorical-1d841b8cb1b6a72ebf6624a836d1874192c8a8fe.tar.gz
historical-1d841b8cb1b6a72ebf6624a836d1874192c8a8fe.tar.bz2
historical-1d841b8cb1b6a72ebf6624a836d1874192c8a8fe.zip
Version bump.
Package-Manager: portage-2.0.53_rc7
-rw-r--r--mail-filter/bogofilter/ChangeLog7
-rw-r--r--mail-filter/bogofilter/Manifest10
-rw-r--r--mail-filter/bogofilter/bogofilter-0.96.6.ebuild77
-rw-r--r--mail-filter/bogofilter/files/digest-bogofilter-0.96.61
4 files changed, 90 insertions, 5 deletions
diff --git a/mail-filter/bogofilter/ChangeLog b/mail-filter/bogofilter/ChangeLog
index a7e67cf46014..e6a34756eb6d 100644
--- a/mail-filter/bogofilter/ChangeLog
+++ b/mail-filter/bogofilter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-filter/bogofilter
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.41 2005/11/08 21:17:35 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.42 2005/11/13 00:19:20 tove Exp $
+
+*bogofilter-0.96.6 (13 Nov 2005)
+
+ 13 Nov 2005; Torsten Veller <tove@gentoo.org> +bogofilter-0.96.6.ebuild:
+ Version bump.
*bogofilter-0.96.5 (08 Nov 2005)
diff --git a/mail-filter/bogofilter/Manifest b/mail-filter/bogofilter/Manifest
index b682e6067eb3..c22413877cdb 100644
--- a/mail-filter/bogofilter/Manifest
+++ b/mail-filter/bogofilter/Manifest
@@ -1,16 +1,18 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 69176691a929778516c34150b92b9dc9 ChangeLog 12996
+MD5 fd55d1ac2c0d6b29badd5249b6b52303 ChangeLog 13122
MD5 28717e3faee82dbca88d83de9c9afadc bogofilter-0.92.8.ebuild 1575
MD5 0fe922bced50c25b4a3a722a910e5bee bogofilter-0.96.5.ebuild 2397
+MD5 1cdbd2008dc3f94c56dee8c593e2b3e1 bogofilter-0.96.6.ebuild 2397
MD5 1970df6e6d8dabe53d04a6f120d0b8bb files/digest-bogofilter-0.92.8 70
MD5 4d0b162c16401cd805a8c5bededda302 files/digest-bogofilter-0.96.5 70
+MD5 4f8372b7a34dce5daa3018232ce35491 files/digest-bogofilter-0.96.6 70
MD5 48bd0f185b30f8151e8da04a025e0373 metadata.xml 424
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDcRX9V3J2n04EauwRAuOSAJ9JUh1ZITvsRifc6PmeqfKx6oEj4gCfUllX
-5of6hp41H5ehuvR/8WdyGkk=
-=8lzB
+iD8DBQFDdoaVV3J2n04EauwRAmTvAJ9DFmQx6PjjSOB7AZyAIRikzPxkXwCgx26h
+tzUOLUqqOcuPiYHpnAJoiWg=
+=KWmV
-----END PGP SIGNATURE-----
diff --git a/mail-filter/bogofilter/bogofilter-0.96.6.ebuild b/mail-filter/bogofilter/bogofilter-0.96.6.ebuild
new file mode 100644
index 000000000000..fbaa5a74c71f
--- /dev/null
+++ b/mail-filter/bogofilter/bogofilter-0.96.6.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/bogofilter-0.96.6.ebuild,v 1.1 2005/11/13 00:19:20 tove Exp $
+
+DESCRIPTION="Bayesian spam filter designed with fast algorithms, and tuned for speed."
+HOMEPAGE="http://bogofilter.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bogofilter/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+#KEYWORDS="${KEYWORDS} ~arm ~mips" # missing, see bug #74046
+IUSE="doc gsl berkdb sqlite"
+
+DEPEND="
+ || ( sys-libs/glibc dev-libs/libiconv )
+ berkdb? ( >=sys-libs/db-3.2 )
+ !berkdb? (
+ sqlite? ( >=dev-db/sqlite-3.2.6 )
+ !sqlite? ( >=sys-libs/db-3.2 ) )
+ gsl? ( sci-libs/gsl )"
+# app-arch/pax" # only needed for bf_tar
+
+src_compile() {
+ local myconf=""
+ myconf="$(use_with !gsl included-gsl)"
+
+ # determine backend: berkdb *is* default
+ if use berkdb && use sqlite ; then
+ einfo "Both berkdb and sqlite are in USE."
+ einfo "Choosing berkdb as default database backend."
+ elif use sqlite ; then
+ myconf="${myconf} --with-database=sqlite"
+ elif ! use berkdb ; then
+ einfo "Using berkdb as database backend."
+ fi
+
+ econf ${myconf} || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ exeinto /usr/share/${PN}/contrib
+ doexe contrib/{bogofilter-qfe,parmtest,randomtrain}.sh \
+ contrib/{bfproxy,bogominitrain,mime.get.rfc822,printmaildir}.pl \
+ contrib/{spamitarium,stripsearch}.pl || die "doexec failed"
+
+ insinto /usr/share/${PN}/contrib
+ doins contrib/{README.*,dot-qmail-bogofilter-default} \
+ contrib/{bogogrep.c,bogo.R,bogofilter-milter.pl,*.example} \
+ contrib/{trainbogo,scramble}.sh || die "doins failed"
+
+ dodoc AUTHORS NEWS README RELEASE.NOTES* TODO GETTING.STARTED \
+ doc/integrating-with-* doc/README.{db,sqlite}
+
+ dodir /usr/share/doc/${PF}/samples
+ mv "${D}"/etc/* "${D}"/usr/share/doc/${PF}/samples/
+ rmdir "${D}"/etc
+
+ if use doc; then
+ dohtml doc/*.html
+ else
+ dohtml doc/bogofilter-faq{,-fr}.html doc/bogofilter-tuning.HOWTO.html
+ fi
+}
+
+pkg_postinst() {
+ ewarn ""
+ ewarn "Incompatible changes in bogofilter-0.93 and -0.94:"
+ ewarn "Please read the documentation (RELEASE.NOTES)!"
+ ewarn ""
+ einfo ""
+ einfo "If you need ${ROOT}usr/bin/bf_tar please install app-arch/pax."
+ einfo ""
+}
diff --git a/mail-filter/bogofilter/files/digest-bogofilter-0.96.6 b/mail-filter/bogofilter/files/digest-bogofilter-0.96.6
new file mode 100644
index 000000000000..2d4acb0af6eb
--- /dev/null
+++ b/mail-filter/bogofilter/files/digest-bogofilter-0.96.6
@@ -0,0 +1 @@
+MD5 24ce45bac5dc7e8ec6bb2f68e5d64a73 bogofilter-0.96.6.tar.bz2 746286