summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-12-16 14:04:33 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-12-16 14:04:33 +0000
commit10f7bb1554341e9585f29eb5c9595684e62a4a2d (patch)
tree0dca34351989b764ec533390e843bb3caa02e9b6
parentRemove old. (diff)
downloadhistorical-10f7bb1554341e9585f29eb5c9595684e62a4a2d.tar.gz
historical-10f7bb1554341e9585f29eb5c9595684e62a4a2d.tar.bz2
historical-10f7bb1554341e9585f29eb5c9595684e62a4a2d.zip
version bump
Package-Manager: portage-2.2_rc59/cvs/Linux x86_64
-rw-r--r--media-video/abby/ChangeLog7
-rw-r--r--media-video/abby/abby-0.4.6.ebuild29
-rw-r--r--media-video/cclive/ChangeLog7
-rw-r--r--media-video/cclive/cclive-0.5.6.ebuild35
4 files changed, 76 insertions, 2 deletions
diff --git a/media-video/abby/ChangeLog b/media-video/abby/ChangeLog
index 2b56162e42c6..cd4d94527d0b 100644
--- a/media-video/abby/ChangeLog
+++ b/media-video/abby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/abby
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/abby/ChangeLog,v 1.8 2009/11/25 10:24:01 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/abby/ChangeLog,v 1.9 2009/12/16 14:04:33 aballier Exp $
+
+*abby-0.4.6 (16 Dec 2009)
+
+ 16 Dec 2009; Alexis Ballier <aballier@gentoo.org> +abby-0.4.6.ebuild:
+ version bump
25 Nov 2009; Markus Meier <maekke@gentoo.org> abby-0.4.2.ebuild:
amd64 stable, bug #284544
diff --git a/media-video/abby/abby-0.4.6.ebuild b/media-video/abby/abby-0.4.6.ebuild
new file mode 100644
index 000000000000..454b6d5fb742
--- /dev/null
+++ b/media-video/abby/abby-0.4.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/abby/abby-0.4.6.ebuild,v 1.1 2009/12/16 14:04:33 aballier Exp $
+
+EAPI="1"
+inherit qt4
+
+DESCRIPTION="GUI front-end for cclive and clive video extraction utilities"
+HOMEPAGE="http://code.google.com/p/abby/"
+SRC_URI="http://abby.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( >=media-video/clive-2.2.5 >=media-video/cclive-0.5.0 )
+ x11-libs/qt-gui:4"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ eqmake4 || die
+ emake || die
+}
+
+src_install() {
+ dobin abby || die
+ dodoc AUTHORS CHANGES README TODO NEWS
+}
diff --git a/media-video/cclive/ChangeLog b/media-video/cclive/ChangeLog
index d05f170642c2..c92e47fb5336 100644
--- a/media-video/cclive/ChangeLog
+++ b/media-video/cclive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/cclive
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cclive/ChangeLog,v 1.9 2009/12/09 19:20:41 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cclive/ChangeLog,v 1.10 2009/12/16 14:01:20 aballier Exp $
+
+*cclive-0.5.6 (16 Dec 2009)
+
+ 16 Dec 2009; Alexis Ballier <aballier@gentoo.org> +cclive-0.5.6.ebuild:
+ version bump
09 Dec 2009; nixnut <nixnut@gentoo.org> cclive-0.5.3.ebuild:
ppc stable #287175
diff --git a/media-video/cclive/cclive-0.5.6.ebuild b/media-video/cclive/cclive-0.5.6.ebuild
new file mode 100644
index 000000000000..5b04c8ae590f
--- /dev/null
+++ b/media-video/cclive/cclive-0.5.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/cclive/cclive-0.5.6.ebuild,v 1.1 2009/12/16 14:01:20 aballier Exp $
+
+EAPI=2
+
+DESCRIPTION="Command line tool for extracting videos from various websites"
+HOMEPAGE="http://code.google.com/p/cclive/"
+SRC_URI="http://cclive.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND=">=net-misc/curl-7.18.0
+ >=dev-libs/libpcre-7.9[cxx]"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --with-man \
+ $(use_enable test tests)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+}
+
+src_test() {
+ einfo "Tests require internet connection in order to work."
+ ADULT_OK="true" emake check || die "emake test failed"
+}