summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-470.57.02.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-470.57.02.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-470.57.02.ebuild
index ea8905ecfe09..a972835bc8a1 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-470.57.02.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-470.57.02.ebuild
@@ -90,6 +90,7 @@ pkg_setup() {
~DRM_KMS_HELPER
~SYSVIPC
~!LOCKDEP
+ ~!SLUB_DEBUG_ON
!DEBUG_MUTEXES"
local ERROR_DRM_KMS_HELPER="CONFIG_DRM_KMS_HELPER: is not set but needed for Xorg auto-detection
of drivers (no custom config), and optional nvidia-drm.modeset=1.
@@ -422,6 +423,12 @@ pkg_postinst() {
use driver && ewarn "The easiest way to fix this is usually to reboot."
fi
+ if [[ $(</proc/cmdline) == *slub_debug=[!-]* ]]; then
+ ewarn "Detected that the current kernel command line is using 'slub_debug=',"
+ ewarn "this may lead to system instability/freezes with this version of"
+ ewarn "${PN}. Bug: https://bugs.gentoo.org/796329"
+ fi
+
if [[ ${NV_LEGACY_MASK} ]]; then
ewarn "You are installing a version of nvidia-drivers known not to work"
ewarn "with a GPU of the current system. If unwanted, add the mask:"