summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/gitea/gitea-1.5.2.ebuild')
-rw-r--r--www-apps/gitea/gitea-1.5.2.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/www-apps/gitea/gitea-1.5.2.ebuild b/www-apps/gitea/gitea-1.5.2.ebuild
deleted file mode 100644
index 49bba0eddfbc..000000000000
--- a/www-apps/gitea/gitea-1.5.2.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit golang-build golang-vcs-snapshot systemd user
-
-EGO_PN="code.gitea.io/gitea"
-KEYWORDS="~amd64 ~arm"
-
-DESCRIPTION="A painless self-hosted Git service, written in Go"
-HOMEPAGE="https://github.com/go-gitea/gitea"
-SRC_URI="https://github.com/go-gitea/gitea/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-
-DEPEND="
- dev-go/go-bindata
- sys-libs/pam
-"
-RDEPEND="
- dev-vcs/git
- sys-libs/pam
-"
-
-pkg_setup() {
- enewgroup git
- enewuser git -1 /bin/bash /var/lib/gitea git
-}
-
-src_prepare() {
- default
- sed -i -e "s/\"main.Version.*$/\"main.Version=${PV}\"/"\
- -e "s/-ldflags '-s/-ldflags '/" src/${EGO_PN}/Makefile || die
-}
-
-src_compile() {
- GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" emake -C src/${EGO_PN} generate
- TAGS="bindata pam sqlite" LDFLAGS="" CGO_LDFLAGS="" GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" emake -C src/${EGO_PN} build
-}
-
-src_install() {
- diropts -m0750 -o git -g git
- keepdir /var/log/gitea /var/lib/gitea /var/lib/gitea/data
- pushd src/${EGO_PN} >/dev/null || die
- dobin gitea
- insinto /var/lib/gitea/conf
- newins custom/conf/app.ini.sample app.ini.example
- popd >/dev/null || die
- newinitd "${FILESDIR}"/gitea.initd-r1 gitea
- newconfd "${FILESDIR}"/gitea.confd gitea
- systemd_dounit "${FILESDIR}/gitea.service"
-}
-
-pkg_postinst() {
- if [[ ! -e "${EROOT}/var/lib/gitea/conf/app.ini" ]]; then
- elog "No app.ini found, copying initial config over"
- cp "${FILESDIR}"/app.ini "${EROOT}"/var/lib/gitea/conf/ || die
- chown git:git /var/lib/gitea/conf/app.ini
- else
- elog "app.ini found, please check example file for possible changes"
- ewarn "Please note that environment variables have been changed:"
- ewarn "GITEA_WORK_DIR is set to /var/lib/gitea (previous value: unset)"
- ewarn "GITEA_CUSTOM is set to '\$GITEA_WORK_DIR/custom' (previous: /var/lib/gitea)"
- fi
-}