summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/extundelete/extundelete-0.2.0-r2.ebuild')
-rw-r--r--sys-fs/extundelete/extundelete-0.2.0-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-fs/extundelete/extundelete-0.2.0-r2.ebuild b/sys-fs/extundelete/extundelete-0.2.0-r2.ebuild
new file mode 100644
index 000000000000..60884ae20e56
--- /dev/null
+++ b/sys-fs/extundelete/extundelete-0.2.0-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+_UNDEL_DEB=2.1
+_UNDEL_E2FS=1.42.6
+
+DESCRIPTION="A utility to undelete files from an ext3 or ext4 partition"
+HOMEPAGE="http://extundelete.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}-${_UNDEL_DEB}.debian.tar.gz"
+
+LICENSE="GPL-2"
+SLOT=0
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-fs/e2fsprogs-${_UNDEL_E2FS}
+ >=sys-libs/e2fsprogs-libs-${_UNDEL_E2FS}"
+DEPEND=${RDEPEND}
+
+DOCS=README
+
+src_prepare() {
+ local d=${WORKDIR}/debian/patches
+ EPATCH_SOURCE=${d} epatch $(<"${d}"/series)
+}