summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/num-utils')
-rw-r--r--sci-mathematics/num-utils/Manifest3
-rw-r--r--sci-mathematics/num-utils/metadata.xml5
-rw-r--r--sci-mathematics/num-utils/num-utils-0.3.ebuild26
-rw-r--r--sci-mathematics/num-utils/num-utils-0.5-r1.ebuild48
4 files changed, 82 insertions, 0 deletions
diff --git a/sci-mathematics/num-utils/Manifest b/sci-mathematics/num-utils/Manifest
new file mode 100644
index 000000000000..8ce9c6aa5632
--- /dev/null
+++ b/sci-mathematics/num-utils/Manifest
@@ -0,0 +1,3 @@
+DIST num-utils-0.3.tar.gz 28208 RMD160 b6ac19c51fa9241dcaa32a9e4ae5ef03b7e469d4 SHA1 8c49d3e54a50220e278244ad1f744877e87209ae SHA256 2369fbd7ef094129d6bc60c54a22e98d2329e9ce7b1b958614991398ec1bff72
+DIST num-utils-0.5.tar.gz 31845 RMD160 54ed62109fdbeaf4fe2006a072e1e4e778ab146c SHA1 3fc6130874129fe1e98db6db8b3dc43f0e1a89ac SHA256 03592760fc7844492163b14ddc9bb4e4d6526e17b468b5317b4a702ea7f6c64e
+DIST num-utils_0.5-11.diff.gz 11702 RMD160 861df640cbf10713d0ac1df5186c29d1b27365e5 SHA1 25e662aab5eaf108598239716ab922b320056ff2 SHA256 6b4294671eff9378579f20904b27ef42ba4bfb2ac0af74007a81b08e6cc917ad
diff --git a/sci-mathematics/num-utils/metadata.xml b/sci-mathematics/num-utils/metadata.xml
new file mode 100644
index 000000000000..2b0bd5314823
--- /dev/null
+++ b/sci-mathematics/num-utils/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-mathematics</herd>
+</pkgmetadata>
diff --git a/sci-mathematics/num-utils/num-utils-0.3.ebuild b/sci-mathematics/num-utils/num-utils-0.3.ebuild
new file mode 100644
index 000000000000..29bc18cc2482
--- /dev/null
+++ b/sci-mathematics/num-utils/num-utils-0.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="A set of programs for dealing with numbers from the command line"
+SRC_URI="http://suso.suso.org/programs/num-utils/downloads/${P}.tar.gz"
+HOMEPAGE="http://suso.suso.org/programs/num-utils/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ dev-lang/perl
+ !<sci-chemistry/gromacs-4"
+
+src_compile() {
+ emake || die
+}
+
+src_install () {
+ make ROOT="${D}" install || die
+ dodoc CHANGELOG GOALS MANIFEST README VERSION WARNING
+}
diff --git a/sci-mathematics/num-utils/num-utils-0.5-r1.ebuild b/sci-mathematics/num-utils/num-utils-0.5-r1.ebuild
new file mode 100644
index 000000000000..5b20afa310d2
--- /dev/null
+++ b/sci-mathematics/num-utils/num-utils-0.5-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DEB_PR=11
+
+DESCRIPTION="A set of programs for dealing with numbers from the command line"
+HOMEPAGE="http://suso.suso.org/programs/num-utils/"
+SRC_URI="
+ http://suso.suso.org/programs/num-utils/downloads/${P}.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}-${DEB_PR}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${WORKDIR}"/${PN}_${PV}-${DEB_PR}.diff
+ sed \
+ -e 's:../orig/num-utils-0.5/::g' \
+ -i "${S}"/debian/patches/*.diff || die
+ epatch "${S}"/debian/patches/*.diff
+
+ local x
+ for x in average bound interval normalize random range round; do
+ mv $x num$x || die "renaming $x failed"
+ done
+
+ sed \
+ -e 's/^RPMDIR/#RPMDIR/' \
+ -e 's/COPYING//' \
+ -e 's/LICENSE//' \
+ -e '/^DOCS/s/MANIFEST//' \
+ -i Makefile || die "sed Makefile failed"
+}
+
+src_install () {
+ emake ROOT="${ED}" install
+}
+
+pkg_postinst() {
+ elog "All ${PN} programs have been renamed with prefix 'num' to avoid collisions"
+}