summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/chemex/chemex-2024.02.16.ebuild')
-rw-r--r--sci-chemistry/chemex/chemex-2024.02.16.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/sci-chemistry/chemex/chemex-2024.02.16.ebuild b/sci-chemistry/chemex/chemex-2024.02.16.ebuild
deleted file mode 100644
index 403e48aa069d..000000000000
--- a/sci-chemistry/chemex/chemex-2024.02.16.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_SINGLE_IMPL="yes"
-DISTUTILS_USE_PEP517=pdm-backend
-PYTHON_COMPAT=( python3_{11..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Program to fit chemical exchange induced shift and relaxation data"
-HOMEPAGE="https://github.com/gbouvignies/chemex"
-SRC_URI="https://github.com/gbouvignies/ChemEx/archive/refs/tags/v${PV/_p/-dev}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/ChemEx-${PV/_p/-dev}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-#RESTRICT="!test? ( test )"
-# FIXME: Restrict until tests are readded https://github.com/gbouvignies/ChemEx/issues/51
-RESTRICT="test"
-
-RDEPEND="
- $(python_gen_cond_dep '
- >=dev-python/annotated-types-0.6.0[${PYTHON_USEDEP}]
- >=dev-python/cachetools-5.3.2[${PYTHON_USEDEP}]
- >=dev-python/emcee-3.1.4[${PYTHON_USEDEP}]
- >=dev-python/lmfit-1.2.2[${PYTHON_USEDEP}]
- >=dev-python/matplotlib-3.8.0[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.26.1[${PYTHON_USEDEP}]
- >=dev-python/pydantic-2.4.2[${PYTHON_USEDEP}]
- >=dev-python/rapidfuzz-3.4.0[${PYTHON_USEDEP}]
- >=dev-python/rich-13.6.0[${PYTHON_USEDEP}]
- >=dev-python/scipy-1.11.3[${PYTHON_USEDEP}]
- >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
- ')
-"
-DEPEND="${RDEPEND}"
-
-distutils_enable_tests pytest
-
-export PDM_BUILD_SCM_VERSION=${PV}