summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/mktorrent')
-rw-r--r--net-p2p/mktorrent/Manifest1
-rw-r--r--net-p2p/mktorrent/metadata.xml8
-rw-r--r--net-p2p/mktorrent/mktorrent-1.0-r1.ebuild34
3 files changed, 43 insertions, 0 deletions
diff --git a/net-p2p/mktorrent/Manifest b/net-p2p/mktorrent/Manifest
new file mode 100644
index 000000000000..733adc34b81e
--- /dev/null
+++ b/net-p2p/mktorrent/Manifest
@@ -0,0 +1 @@
+DIST mktorrent-1.0.tar.gz 23089 SHA256 6f8e562af6366e0d9bde76e434f740b55722c6c3c555860dbe80083f9d1d119f SHA512 f103c8860c008796c2dc604fcabce7374264fd7814237fcad5f9dab0fe10e927b0e2d9b58e7462dd198265a7d83fe30fd68313c7dce4029d8c331a6f2d4622de WHIRLPOOL 2a907fe846ae5a35dbb38fbd6707a89121d34b9658f1afa682db14da9254cc58ed376fc23c834753409769643868294b0f1354fd7d9d567ec0cff49ee713b163
diff --git a/net-p2p/mktorrent/metadata.xml b/net-p2p/mktorrent/metadata.xml
new file mode 100644
index 000000000000..5907da4c707e
--- /dev/null
+++ b/net-p2p/mktorrent/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-p2p</herd>
+ <upstream>
+ <remote-id type="sourceforge">mktorrent</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-p2p/mktorrent/mktorrent-1.0-r1.ebuild b/net-p2p/mktorrent/mktorrent-1.0-r1.ebuild
new file mode 100644
index 000000000000..22c51689aaba
--- /dev/null
+++ b/net-p2p/mktorrent/mktorrent-1.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Simple command line utility to create BitTorrent metainfo files"
+HOMEPAGE="http://mktorrent.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="threads +ssl debug"
+
+RDEPEND="ssl? ( dev-libs/openssl:0 )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ tc-export CC
+ MAKEPARAM="USE_LONG_OPTIONS=1"
+ MAKEPARAM="${MAKEPARAM} USE_LARGE_FILES=1"
+ use debug && MAKEPARAM="${MAKEPARAM} DEBUG=1"
+ use ssl && MAKEPARAM="${MAKEPARAM} USE_OPENSSL=1"
+ use threads && MAKEPARAM="${MAKEPARAM} USE_PTHREADS=1"
+
+ emake ${MAKEPARAM}
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+}