summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild')
-rw-r--r--net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild b/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
index 0eceaac74e02..79dc792325fc 100644
--- a/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
+++ b/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit cmake-utils python-single-r1
@@ -11,11 +11,11 @@ HOMEPAGE="https://sdr.osmocom.org/trac/wiki/fosphor"
if [[ ${PV} == 9999* ]]; then
inherit git-r3
- #EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
EGIT_REPO_URI="https://github.com/osmocom/${PN}.git"
- EGIT_BRANCH="gr3.7-qt5"
else
- SRC_URI="mirror://gentoo/${P}.tar.xz"
+ COMMIT="fa6761afbf8c2658782e0c7fc5d51063679b7ae4"
+ SRC_URI="https://github.com/osmocom/gr-fosphor/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
KEYWORDS="~amd64 ~x86"
fi
@@ -23,7 +23,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
LICENSE="GPL-3+"
SLOT="0"
-IUSE="glfw qt5 wxwidgets"
+IUSE="glfw qt5"
RDEPEND="qt5? (
dev-qt/qtcore:5
@@ -31,7 +31,7 @@ RDEPEND="qt5? (
dev-qt/qtopengl:5
dev-qt/qtwidgets:5
)
- >=net-wireless/gnuradio-3.7_rc:0=[qt5,wxwidgets?,${PYTHON_SINGLE_USEDEP}]
+ =net-wireless/gnuradio-3.8*:0=[qt5,${PYTHON_SINGLE_USEDEP}]
media-libs/freetype
dev-libs/boost:=
glfw? ( >=media-libs/glfw-3 )