summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/konsole')
-rw-r--r--kde-apps/konsole/files/konsole-16.12.1-ecm531.patch22
-rw-r--r--kde-apps/konsole/konsole-16.12.1.ebuild2
2 files changed, 24 insertions, 0 deletions
diff --git a/kde-apps/konsole/files/konsole-16.12.1-ecm531.patch b/kde-apps/konsole/files/konsole-16.12.1-ecm531.patch
new file mode 100644
index 000000000000..fd22781b3375
--- /dev/null
+++ b/kde-apps/konsole/files/konsole-16.12.1-ecm531.patch
@@ -0,0 +1,22 @@
+commit 3a055ea19d5f458ccf06a33c697fbcda7a7f14df
+Author: Aleix Pol <aleixpol@kde.org>
+Date: Wed Jan 18 12:15:00 2017 +0100
+
+ Fix build
+
+ frameworks/konsole/src/Session.cpp:839:5: warning: 'not' is not defined,
+ evaluates to 0 [-Wundef]
+
+diff --git a/src/Session.cpp b/src/Session.cpp
+index d63c8a0..482ee0b 100644
+--- a/src/Session.cpp
++++ b/src/Session.cpp
+@@ -836,7 +836,7 @@ void Session::sendTextToTerminal(const QString& text, const QChar& eol) const
+ // Only D-Bus calls this function (via SendText or runCommand)
+ void Session::sendText(const QString& text) const
+ {
+-#if not defined(REMOVE_SENDTEXT_RUNCOMMAND_DBUS_METHODS)
++#if !defined(REMOVE_SENDTEXT_RUNCOMMAND_DBUS_METHODS)
+ if (show_disallow_certain_dbus_methods_message) {
+
+ KNotification::event(KNotification::Warning, "Konsole D-Bus Warning",
diff --git a/kde-apps/konsole/konsole-16.12.1.ebuild b/kde-apps/konsole/konsole-16.12.1.ebuild
index 1070cde13ade..ea4c0fec62d1 100644
--- a/kde-apps/konsole/konsole-16.12.1.ebuild
+++ b/kde-apps/konsole/konsole-16.12.1.ebuild
@@ -49,6 +49,8 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-ecm531.patch" )
+
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package X X11)