summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild')
-rw-r--r--games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild b/games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild
new file mode 100644
index 000000000000..5d37d87c35b6
--- /dev/null
+++ b/games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="remake of the Atari 2600 classic Yar's Revenge"
+HOMEPAGE="http://freshmeat.net/projects/yarsrevenge/"
+SRC_URI="http://www.autismuk.freeserve.co.uk/yar-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,joystick,video]"
+RDEPEND="${DEPEND}"
+S=${WORKDIR}/yar-${PV}
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-math.patch
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-gcc44.patch
+)
+
+src_install() {
+ default
+ prepgamesdirs
+}