summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/fakk2')
-rw-r--r--games-action/fakk2/fakk2-1.02.ebuild68
-rw-r--r--games-action/fakk2/metadata.xml8
2 files changed, 76 insertions, 0 deletions
diff --git a/games-action/fakk2/fakk2-1.02.ebuild b/games-action/fakk2/fakk2-1.02.ebuild
new file mode 100644
index 000000000000..508b6dc5b684
--- /dev/null
+++ b/games-action/fakk2/fakk2-1.02.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils cdrom games
+
+DESCRIPTION="Heavy Metal: FAKK2 - 3D third-person action shooter based on the Heavy Metal comics/movies"
+HOMEPAGE="http://www.lokigames.com/products/fakk2/"
+SRC_URI=""
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="nocd"
+RESTRICT="strip"
+
+RDEPEND="virtual/opengl"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+pkg_setup() {
+ games_pkg_setup
+ if use nocd ; then
+ ewarn "The installed game takes about 378MB of space!"
+ fi
+}
+
+src_install() {
+ cdrom_get_cds fakk
+ einfo "Copying files... this may take a while..."
+ exeinto "${dir}"
+ doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/${PN}
+ insinto "${dir}"
+ doins ${CDROM_ROOT}/{README,icon.{bmp,xpm}}
+ exeinto "${dir}"/fakk
+ doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/fakk/{c,f}game.so
+ if use nocd ; then
+ insinto "${dir}"/fakk
+ doins ${CDROM_ROOT}/fakk/pak{0,1,2,3}.pk3
+ doins ${CDROM_ROOT}/fakk/default.cfg
+ fi
+
+ # now, since these files are coming off a cd, the times/sizes/md5sums wont
+ # be different ... that means portage will try to unmerge some files (!)
+ # we run touch on ${D} so as to make sure portage doesnt do any such thing
+ find "${Ddir}" -exec touch '{}' \;
+
+ games_make_wrapper ${PN} ./${PN} "${dir}" "${dir}"
+ newicon ${CDROM_ROOT}/icon.xpm ${PN}.xpm
+
+ prepgamesdirs
+ make_desktop_entry ${PN} "FAKK2" ${PN}
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ ewarn "There are two possible security bugs in this package, both causing a denial of"
+ ewarn "service. One affects the game when running a server, the other when running as"
+ ewarn "a client. For more information, see bug #82149."
+ echo
+ elog "To play the game run:"
+ elog " fakk2"
+}
diff --git a/games-action/fakk2/metadata.xml b/games-action/fakk2/metadata.xml
new file mode 100644
index 000000000000..1f425a350d7e
--- /dev/null
+++ b/games-action/fakk2/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+Heavy Metal: F.A.K.K.2 is a third-person 3-D action game based on characters from the Heavy Metal comics and movies. Years have passed since Julie Strain (a.k.a. F.A.K.K.2) defeated the would-be God Lord Tyler on the bloody battlefields of the Holy Land. She has long since put the pain of those days behind her and brought her homeworld of Eden to a perfect natural balance. But far away in the deepest nebulas of space, the greatest evil of all stirs, ready to make its final move -- to take control of the entire universe. A lone beacon hurtles toward Eden, hoping to summon the god-slayer F.A.K.K.2 one last time. It bears nothing more than an onimous warning: "GITH IS COMING." The game was ported to Linux by the now defunct Loki Entertainment and is commercial software. You can still pick up a copy from Tuxgames (http://www.tuxgames.com), but supplies are limited, as the publisher is no longer in business.
+</longdescription>
+</pkgmetadata>