summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/py-spy/py-spy-0.3.14.ebuild')
-rw-r--r--dev-util/py-spy/py-spy-0.3.14.ebuild172
1 files changed, 0 insertions, 172 deletions
diff --git a/dev-util/py-spy/py-spy-0.3.14.ebuild b/dev-util/py-spy/py-spy-0.3.14.ebuild
deleted file mode 100644
index 65e358cfa93e..000000000000
--- a/dev-util/py-spy/py-spy-0.3.14.ebuild
+++ /dev/null
@@ -1,172 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Autogenerated by pycargoebuild 0.6.2
-
-EAPI=8
-
-CRATES="
- addr2line-0.18.0
- adler-1.0.2
- ahash-0.7.6
- aho-corasick-0.7.18
- ansi_term-0.12.1
- anyhow-1.0.58
- arrayvec-0.4.12
- atty-0.2.14
- autocfg-1.1.0
- bindgen-0.59.2
- bitflags-1.3.2
- bytemuck-1.11.0
- cc-1.0.73
- cexpr-0.6.0
- cfg-if-1.0.0
- chrono-0.4.19
- clang-sys-1.3.3
- clap-2.34.0
- clap-3.2.15
- clap_complete-3.2.3
- clap_derive-3.2.15
- clap_lex-0.2.4
- console-0.15.1
- cpp_demangle-0.3.5
- crc32fast-1.3.2
- crossbeam-channel-0.5.6
- crossbeam-utils-0.8.11
- ctrlc-3.2.2
- dashmap-5.3.4
- either-1.7.0
- encode_unicode-0.3.6
- env_logger-0.9.0
- errno-0.2.8
- errno-dragonfly-0.1.2
- fallible-iterator-0.2.0
- fastrand-1.8.0
- flate2-1.0.24
- getrandom-0.2.7
- gimli-0.26.2
- glob-0.3.0
- goblin-0.5.3
- hashbrown-0.12.3
- heck-0.4.0
- hermit-abi-0.1.19
- humantime-2.1.0
- indexmap-1.9.1
- indicatif-0.16.2
- inferno-0.11.7
- instant-0.1.12
- itoa-0.4.8
- itoa-1.0.2
- lazy_static-1.4.0
- lazycell-1.3.0
- libc-0.2.126
- libloading-0.7.3
- libm-0.2.2
- libproc-0.10.0
- libproc-0.12.0
- lock_api-0.4.7
- log-0.4.17
- lru-0.7.8
- mach-0.3.2
- mach2-0.4.1
- mach_o_sys-0.1.1
- memchr-2.5.0
- memmap-0.7.0
- minimal-lexical-0.2.1
- miniz_oxide-0.5.3
- nix-0.24.2
- nodrop-0.1.14
- nom-7.1.1
- num-format-0.4.0
- num-integer-0.1.45
- num-traits-0.2.15
- num_cpus-1.13.1
- number_prefix-0.4.0
- object-0.29.0
- once_cell-1.13.0
- os_str_bytes-6.2.0
- parking_lot_core-0.9.3
- peeking_take_while-0.1.2
- plain-0.2.3
- ppv-lite86-0.2.16
- proc-macro-error-1.0.4
- proc-macro-error-attr-1.0.4
- proc-macro2-1.0.42
- proc-maps-0.2.1
- quick-xml-0.23.0
- quote-1.0.20
- rand-0.8.5
- rand_chacha-0.3.1
- rand_core-0.6.3
- rand_distr-0.4.3
- read-process-memory-0.1.4
- redox_syscall-0.2.16
- regex-1.6.0
- regex-syntax-0.6.27
- remoteprocess-0.4.10
- remove_dir_all-0.5.3
- rgb-0.8.33
- rustc-demangle-0.1.21
- rustc-hash-1.1.0
- ryu-1.0.10
- scopeguard-1.1.0
- scroll-0.11.0
- scroll_derive-0.11.0
- serde-1.0.140
- serde_derive-1.0.140
- serde_json-1.0.82
- shlex-1.1.0
- smallvec-1.9.0
- stable_deref_trait-1.2.0
- str_stack-0.1.0
- strsim-0.10.0
- strsim-0.8.0
- syn-1.0.98
- tempfile-3.3.0
- termcolor-1.1.3
- terminal_size-0.1.17
- termios-0.3.3
- textwrap-0.11.0
- textwrap-0.15.0
- time-0.1.44
- unicode-ident-1.0.2
- unicode-width-0.1.9
- vec_map-0.8.2
- version_check-0.9.4
- wasi-0.10.0+wasi-snapshot-preview1
- wasi-0.11.0+wasi-snapshot-preview1
- which-4.2.5
- winapi-0.3.9
- winapi-i686-pc-windows-gnu-0.4.0
- winapi-util-0.1.5
- winapi-x86_64-pc-windows-gnu-0.4.0
- windows-sys-0.36.1
- windows_aarch64_msvc-0.36.1
- windows_i686_gnu-0.36.1
- windows_i686_msvc-0.36.1
- windows_x86_64_gnu-0.36.1
- windows_x86_64_msvc-0.36.1
-"
-
-inherit cargo
-
-DESCRIPTION="Sampling profiler for Python programs"
-HOMEPAGE="https://github.com/benfred/py-spy"
-SRC_URI="
- https://github.com/benfred/py-spy/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz
- $(cargo_crate_uris)
-"
-
-LICENSE="MIT"
-# Dependent crate licenses
-LICENSE+=" Apache-2.0 BSD-2 BSD CDDL ISC MIT Unicode-DFS-2016"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-# python_data_access::tests::test_copy_string fails
-RESTRICT="test"
-
-# Really does need libunwind, not llvm-libunwind, as needs e.g. -ptrace.
-DEPEND="sys-libs/libunwind:="
-RDEPEND="${DEPEND}"
-
-QA_FLAGS_IGNORED="usr/bin/py-spy"