summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/reportlab/reportlab-2.6.ebuild')
-rw-r--r--dev-python/reportlab/reportlab-2.6.ebuild78
1 files changed, 0 insertions, 78 deletions
diff --git a/dev-python/reportlab/reportlab-2.6.ebuild b/dev-python/reportlab/reportlab-2.6.ebuild
deleted file mode 100644
index aec4578664ca..000000000000
--- a/dev-python/reportlab/reportlab-2.6.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-# Tests crash with pypy
-
-inherit distutils-r1 eutils flag-o-matic prefix
-
-DESCRIPTION="Tools for generating printable PDF documents from any data source"
-HOMEPAGE="http://www.reportlab.com/ https://pypi.python.org/pypi/reportlab"
-SRC_URI="http://www.reportlab.com/ftp/${P}.tar.gz
- http://www.reportlab.com/ftp/fonts/pfbfer-20070710.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc examples"
-
-RDEPEND="dev-python/pillow
- media-fonts/ttf-bitstream-vera
- media-libs/libart_lgpl
- sys-libs/zlib"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-src_unpack() {
- unpack ${P}.tar.gz
- cd ${P}/src/reportlab/fonts || die
- unpack pfbfer-20070710.zip
-}
-
-python_prepare_all() {
- sed -i \
- -e 's|/usr/lib/X11/fonts/TrueType/|/usr/share/fonts/ttf-bitstream-vera/|' \
- -e 's|/usr/local/Acrobat|/opt/Acrobat|g' \
- -e 's|%(HOME)s/fonts|%(HOME)s/.fonts|g' \
- src/reportlab/rl_config.py || die "sed failed"
-
- epatch "${FILESDIR}/${PN}-2.2_qa_msg.patch"
-
- rm -fr src/rl_addons/renderPM/libart_lgpl
- epatch "${FILESDIR}/${PN}-2.4-external_libart_lgpl.patch"
-
- eprefixify setup.py
-
- epatch "${FILESDIR}/${PN}-2.5-pypy-implicit-PyArg_NoArgs.patch"
-}
-
-src_compile() {
- append-cflags -fno-strict-aliasing
- distutils-r1_src_compile
-}
-
-python_compile_all() {
- if use doc; then
- cd docs || die
- "${PYTHON}" genAll.py || die "docs generation failed"
- fi
-}
-
-python_test() {
- pushd tests > /dev/null || die
- "${PYTHON}" runAll.py || die "Testing failed with ${EPYTHON}"
- popd > /dev/null || die
-}
-
-python_install_all() {
- use doc && dodoc docs/*.pdf
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r demos
- insinto /usr/share/doc/${PF}/tools/pythonpoint
- doins -r tools/pythonpoint/demos
- fi
- distutils-r1_python_install_all
-}