summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/qtconsole/qtconsole-4.1.1.ebuild')
-rw-r--r--dev-python/qtconsole/qtconsole-4.1.1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-python/qtconsole/qtconsole-4.1.1.ebuild b/dev-python/qtconsole/qtconsole-4.1.1.ebuild
index a7c0411f2e34..5c5587cebdb5 100644
--- a/dev-python/qtconsole/qtconsole-4.1.1.ebuild
+++ b/dev-python/qtconsole/qtconsole-4.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -29,11 +29,16 @@ DEPEND="${RDEPEND}
)
test? (
>=dev-python/nose-0.10.1[${PYTHON_USEDEP}]
+ || (
+ dev-python/pyside[${PYTHON_USEDEP},svg]
+ dev-python/PyQt5[${PYTHON_USEDEP},svg,testlib]
+ dev-python/PyQt4[${PYTHON_USEDEP},svg,testlib]
+ )
)
|| (
dev-python/pyside[${PYTHON_USEDEP},svg]
- dev-python/PyQt4[${PYTHON_USEDEP},svg]
dev-python/PyQt5[${PYTHON_USEDEP},svg]
+ dev-python/PyQt4[${PYTHON_USEDEP},svg]
)
dev-python/pygments[${PYTHON_USEDEP}]
>=dev-python/pyzmq-13[${PYTHON_USEDEP}]