summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/httpbin')
-rw-r--r--dev-python/httpbin/files/httpbin-0.7.0-brotlicffi.patch2
-rw-r--r--dev-python/httpbin/files/httpbin-0.7.0-optional-raven.patch12
-rw-r--r--dev-python/httpbin/httpbin-0.7.0-r3.ebuild (renamed from dev-python/httpbin/httpbin-0.7.0-r2.ebuild)2
3 files changed, 14 insertions, 2 deletions
diff --git a/dev-python/httpbin/files/httpbin-0.7.0-brotlicffi.patch b/dev-python/httpbin/files/httpbin-0.7.0-brotlicffi.patch
index f74474a70aa1..8031ad72de5b 100644
--- a/dev-python/httpbin/files/httpbin-0.7.0-brotlicffi.patch
+++ b/dev-python/httpbin/files/httpbin-0.7.0-brotlicffi.patch
@@ -35,7 +35,7 @@ index 7f9956b..8e17ef3 100644
install_requires=[
- 'Flask', 'MarkupSafe', 'decorator', 'itsdangerous', 'six', 'brotlipy',
+ 'Flask', 'MarkupSafe', 'decorator', 'itsdangerous', 'six', 'brotlicffi',
- 'raven[flask]', 'werkzeug>=0.14.1'
+ 'werkzeug>=0.14.1'
],
)
--
diff --git a/dev-python/httpbin/files/httpbin-0.7.0-optional-raven.patch b/dev-python/httpbin/files/httpbin-0.7.0-optional-raven.patch
index 8602ed7641be..5d626768bd27 100644
--- a/dev-python/httpbin/files/httpbin-0.7.0-optional-raven.patch
+++ b/dev-python/httpbin/files/httpbin-0.7.0-optional-raven.patch
@@ -17,3 +17,15 @@ diff -dupr a/httpbin/core.py b/httpbin/core.py
sentry = Sentry(app, dsn=os.environ['SENTRY_DSN'])
# Set up Bugsnag exception tracking, if desired. To use Bugsnag, install the
+diff --git a/setup.py b/setup.py
+index 7f9956b..3cab2ae 100644
+--- a/setup.py
++++ b/setup.py
+@@ -35,6 +35,6 @@ setup(
+ include_package_data = True, # include files listed in MANIFEST.in
+ install_requires=[
+ 'Flask', 'MarkupSafe', 'decorator', 'itsdangerous', 'six', 'brotlipy',
+- 'raven[flask]', 'werkzeug>=0.14.1'
++ 'werkzeug>=0.14.1'
+ ],
+ )
diff --git a/dev-python/httpbin/httpbin-0.7.0-r2.ebuild b/dev-python/httpbin/httpbin-0.7.0-r3.ebuild
index 8c04217f15d8..99f8b0295ddd 100644
--- a/dev-python/httpbin/httpbin-0.7.0-r2.ebuild
+++ b/dev-python/httpbin/httpbin-0.7.0-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7