summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cli_helpers')
-rw-r--r--dev-python/cli_helpers/Manifest1
-rw-r--r--dev-python/cli_helpers/cli_helpers-2.1.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/cli_helpers/Manifest b/dev-python/cli_helpers/Manifest
index 08e26f057890..cdad95559f6e 100644
--- a/dev-python/cli_helpers/Manifest
+++ b/dev-python/cli_helpers/Manifest
@@ -1 +1,2 @@
DIST cli_helpers-2.0.1.tar.gz 32633 BLAKE2B 4bb66cd86871b18f52c737a06968a56098151273ab0a87386db62543961f3a699f37018f9e722a55635dca3136253c59a50d3ec7cb6ebb68d833abe2a320526c SHA512 e470eff51760c5e80d01a318eeb3d91510bd34ed7c094c4196342a74306ec0fe0751514d2ef2a5f77570d8434d417557cc83a8c34d0febdbc7c2cce7b1faf8a6
+DIST cli_helpers-2.1.0.tar.gz 32967 BLAKE2B c2ee2a92dce4185f656415d6079196953c5e9dccf9de4e29d9de61bf72b041a6225ffe4afa866b0f78abcd5d0809ec739db489aee21e440575b7e2a6e09b916a SHA512 75c6b24ae1ed05cbdfddfc30c5e43aeb7129f5fa319d485e19be098691762ad681c4874449b2f339f833424a970965b5a28a3b66814cb556ea8ad6293740fdbe
diff --git a/dev-python/cli_helpers/cli_helpers-2.1.0.ebuild b/dev-python/cli_helpers/cli_helpers-2.1.0.ebuild
new file mode 100644
index 000000000000..b4159629ae3a
--- /dev/null
+++ b/dev-python/cli_helpers/cli_helpers-2.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Python helpers for common CLI tasks"
+HOMEPAGE="https://cli-helpers.rtfd.io/"
+SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/terminaltables-3.0.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest