summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/smarty')
-rw-r--r--dev-php/smarty/Manifest3
-rw-r--r--dev-php/smarty/metadata.xml13
-rw-r--r--dev-php/smarty/smarty-3.1.21-r1.ebuild48
-rw-r--r--dev-php/smarty/smarty-3.1.27.ebuild45
4 files changed, 109 insertions, 0 deletions
diff --git a/dev-php/smarty/Manifest b/dev-php/smarty/Manifest
new file mode 100644
index 000000000000..7931ce8f4d4a
--- /dev/null
+++ b/dev-php/smarty/Manifest
@@ -0,0 +1,3 @@
+DIST Smarty-3.1.21.tar.gz 208308 SHA256 e872f98a194a31b9dea710fceb308431c0e2b846e46ce845b547f54e5789c465 SHA512 018b85f9b8f0de5b5c796cc7ee250159e3e0eba3d91344ce619cc96f2bab45510d49a240938c2b15820cfef9f6de52121194db7d9991559a3e58c31288fa46af WHIRLPOOL 9bbc8965bb8fb1394abf2dbb564fbc62af9259f285952cd9cdc69dd06e9f615f5fbb4e39c408e69b926107ab9c2f958af927c80d4d3792d4dee2a7da68f442c2
+DIST manual-en.3.1.14.zip 408414 SHA256 3aabe51e932b790d24dd8a3c77188b43b99a127f3adaeb0108f085c310404850 SHA512 d384e3856b45ed3f992f3732a5465120abe9fb947cdf13ff67a9c4264f72987d24885ee61cd7309b728e64cdfe4f34c3e7f757096d35de56d962f3b78def9e58 WHIRLPOOL 33dd45ea6cd7bc1129625eb72417fae7c41226a92a6aaddcb72c4426517bd465529599fd8bfc259d8bc3f70f7cd064ada020da4ea7d260cf9801af6944db29f4
+DIST smarty-3.1.27.tar.gz 226277 SHA256 56851d938fde2133331263d0e7788a6f8428f00a97e8d58f486983e64afe6415 SHA512 3ccb17c13a35070fdf50bc641bf6e218890013881fdd5ee03ed5d14c314d646b4aabcfe723a59723bd1c10dd2b63dd92110cf2505edeb5c45ca32ce6ce623ca2 WHIRLPOOL d15f6b7c0753262e9d9a698fdd877b7e5466a0b8d4a59c21e5cce2ed0cd7177bc5e02709e7af7bd312af1bc5e5658bd284eda04b5233c55ede7e491e9c617aef
diff --git a/dev-php/smarty/metadata.xml b/dev-php/smarty/metadata.xml
new file mode 100644
index 000000000000..3bcc6b223fda
--- /dev/null
+++ b/dev-php/smarty/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+ <longdescription lang="en">
+ Smarty is a template engine for PHP, facilitating the separation of
+ presentation (HTML/CSS) from application logic. This implies that PHP
+ code is application logic, and is separated from the presentation.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">smarty-php/smarty</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/smarty/smarty-3.1.21-r1.ebuild b/dev-php/smarty/smarty-3.1.21-r1.ebuild
new file mode 100644
index 000000000000..a8a05a84236b
--- /dev/null
+++ b/dev-php/smarty/smarty-3.1.21-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="Smarty-${PV}"
+DOC_PV="3.1.14"
+
+DESCRIPTION="A template engine for PHP"
+HOMEPAGE="http://www.smarty.net/"
+SRC_URI="http://www.smarty.net/files/${MY_P}.tar.gz
+ doc? ( http://www.smarty.net/files/docs/manual-en.${DOC_PV}.zip )"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-arch/unzip )"
+
+# PHP unicode support is detected at runtime, and the cached templates
+# that smarty generates depend on it. If, later on, PHP is reinstalled
+# without unicode support, all of the previously-generated cached
+# templates will begin to throw 500 errrors for missing mb_foo
+# functions. See bug #532618.
+RDEPEND="dev-lang/php[unicode]"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto "/usr/share/php/${PN}"
+ doins -r libs/*
+
+ dodoc *.txt README
+ use doc && dohtml -r "${WORKDIR}/manual-en/"*
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog
+ elog 'To use it in your scripts, include the Smarty.class.php file'
+ elog "from the \"${PN}\" directory; for example,"
+ elog
+ elog " require('${PN}/Smarty.class.php');"
+ elog
+ elog 'After that, the Smarty class will be available to you.'
+}
diff --git a/dev-php/smarty/smarty-3.1.27.ebuild b/dev-php/smarty/smarty-3.1.27.ebuild
new file mode 100644
index 000000000000..821c82c452ee
--- /dev/null
+++ b/dev-php/smarty/smarty-3.1.27.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DOC_PV="3.1.14"
+
+DESCRIPTION="A template engine for PHP"
+HOMEPAGE="http://www.smarty.net/"
+SRC_URI="https://github.com/smarty-php/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ doc? ( http://www.smarty.net/files/docs/manual-en.${DOC_PV}.zip )"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-arch/unzip )"
+
+# PHP unicode support is detected at runtime, and the cached templates
+# that smarty generates depend on it. If, later on, PHP is reinstalled
+# without unicode support, all of the previously-generated cached
+# templates will begin to throw 500 errrors for missing mb_foo
+# functions. See bug #532618.
+RDEPEND="dev-lang/php[unicode]"
+
+src_install() {
+ insinto "/usr/share/php/${PN}"
+ doins -r libs/*
+
+ dodoc *.txt README
+ use doc && dohtml -r "${WORKDIR}/manual-en/"*
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog
+ elog 'To use it in your scripts, include the Smarty.class.php file'
+ elog "from the \"${PN}\" directory; for example,"
+ elog
+ elog " require('${PN}/Smarty.class.php');"
+ elog
+ elog 'After that, the Smarty class will be available to you.'
+}