summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/chell')
-rw-r--r--dev-haskell/chell/Manifest1
-rw-r--r--dev-haskell/chell/chell-0.4.0.1.ebuild36
-rw-r--r--dev-haskell/chell/metadata.xml45
3 files changed, 82 insertions, 0 deletions
diff --git a/dev-haskell/chell/Manifest b/dev-haskell/chell/Manifest
new file mode 100644
index 000000000000..298b65236a52
--- /dev/null
+++ b/dev-haskell/chell/Manifest
@@ -0,0 +1 @@
+DIST chell-0.4.0.1.tar.gz 12441 SHA256 5f0abd31f4b00483e4667090c89828eda6a1c6ba5d77ecec418ad0fe972a6951 SHA512 5a11e38fdd6c4f323d077dc3adc35c9626229a49f6ed32a0202031094f2612ec3e26a28f96819366439c1ec97ddfd839050f207d03c90a749890ef2bb345b8c3 WHIRLPOOL d9565ca5b23f983f393f8455fb83ac966a0a42ebbea9fd2eff1998cee2d2616feb4dace276ceb36d0df5a5c56e722c13e650325e1b7a50b109fa72ccf742ee17
diff --git a/dev-haskell/chell/chell-0.4.0.1.ebuild b/dev-haskell/chell/chell-0.4.0.1.ebuild
new file mode 100644
index 000000000000..234073f3dcb7
--- /dev/null
+++ b/dev-haskell/chell/chell-0.4.0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A simple and intuitive library for automated testing"
+HOMEPAGE="https://john-millikin.com/software/chell/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+color-output"
+
+RDEPEND=">=dev-haskell/options-1.0:=[profile?] <dev-haskell/options-2.0:=[profile?]
+ >=dev-haskell/patience-0.1:=[profile?] <dev-haskell/patience-0.2:=[profile?]
+ >=dev-haskell/random-1.0:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ color-output? ( >=dev-haskell/ansi-terminal-0.5:=[profile?] <dev-haskell/ansi-terminal-0.7:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag color-output color-output)
+}
diff --git a/dev-haskell/chell/metadata.xml b/dev-haskell/chell/metadata.xml
new file mode 100644
index 000000000000..3e81fb4c1f60
--- /dev/null
+++ b/dev-haskell/chell/metadata.xml
@@ -0,0 +1,45 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Chell is a simple and intuitive library for automated testing. It natively
+ supports assertion-based testing, and can use companion libraries
+ such as @chell-quickcheck@ to support more complex testing strategies.
+
+ An example test suite, which verifies the behavior of artithmetic operators.
+
+ @
+ &amp;#x7b;-\# LANGUAGE TemplateHaskell \#-&amp;#x7d;
+
+ import Test.Chell
+
+ tests_Math :: Suite
+ tests_Math = suite \&quot;math\&quot;
+ &amp;#x20; test_Addition
+ &amp;#x20; test_Subtraction
+
+ test_Addition :: Test
+ test_Addition = assertions \&quot;addition\&quot; $ do
+ &amp;#x20; $expect (equal (2 + 1) 3)
+ &amp;#x20; $expect (equal (1 + 2) 3)
+
+ test_Subtraction :: Test
+ test_Subtraction = assertions \&quot;subtraction\&quot; $ do
+ &amp;#x20; $expect (equal (2 - 1) 1)
+ &amp;#x20; $expect (equal (1 - 2) (-1))
+
+ main :: IO ()
+ main = defaultMain [tests_Math]
+ @
+
+ @
+ $ ghc --make chell-example.hs
+ $ ./chell-example
+ PASS: 2 tests run, 2 tests passed
+ @
+ </longdescription>
+ <use>
+ <flag name="color-output">use colors in program output</flag>
+ </use>
+</pkgmetadata>