summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/pushpop/pushpop-4.0-r2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/app-vim/pushpop/pushpop-4.0-r2.ebuild b/app-vim/pushpop/pushpop-4.0-r2.ebuild
new file mode 100644
index 000000000000..0e1f79e43ff9
--- /dev/null
+++ b/app-vim/pushpop/pushpop-4.0-r2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: pushd / popd from the vim commandline"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=129"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+
+RDEPEND="
+ >=app-vim/genutils-1.1
+ >=app-vim/cmdalias-1.0"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides :Pushd and :Popd commands which emulate bash's pushd
+and popd functions."