summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/peco/peco-0.5.10.ebuild')
-rw-r--r--app-shells/peco/peco-0.5.10.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-shells/peco/peco-0.5.10.ebuild b/app-shells/peco/peco-0.5.10.ebuild
new file mode 100644
index 000000000000..7b6fc14153bc
--- /dev/null
+++ b/app-shells/peco/peco-0.5.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Simplistic interactive filtering tool"
+HOMEPAGE="https://github.com/peco/peco"
+SRC_URI="https://github.com/peco/peco/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+ https://github.com/SpiderX/portage-overlay/raw/deps/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( {Changes,README.md} )
+
+src_compile() {
+ ego build ./cmd/...
+}
+
+src_test() {
+ ego test ./...
+}
+
+src_install() {
+ einstalldocs
+ dobin peco
+}