summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild')
-rw-r--r--app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild b/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild
new file mode 100644
index 000000000000..5548aa8092b3
--- /dev/null
+++ b/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit autotools eutils
+
+DESCRIPTION="Wijesekara keyboard for Sinhala input using scim"
+HOMEPAGE="http://sinhala.sourceforge.net/"
+SRC_URI="http://sinhala.sourceforge.net/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/scim-0.99.8[-gtk3]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README
+}