summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/navi2ch')
-rw-r--r--app-emacs/navi2ch/Manifest2
-rw-r--r--app-emacs/navi2ch/files/50navi2ch-gentoo.el2
-rw-r--r--app-emacs/navi2ch/metadata.xml9
-rw-r--r--app-emacs/navi2ch/navi2ch-1.8.3-r1.ebuild51
-rw-r--r--app-emacs/navi2ch/navi2ch-1.8.4.ebuild51
5 files changed, 115 insertions, 0 deletions
diff --git a/app-emacs/navi2ch/Manifest b/app-emacs/navi2ch/Manifest
new file mode 100644
index 000000000000..629846378e91
--- /dev/null
+++ b/app-emacs/navi2ch/Manifest
@@ -0,0 +1,2 @@
+DIST navi2ch-1.8.3.tar.gz 477433 SHA256 671091f831e97ad05a1d106697fdbb7447201df209af550bf60ea6a71f7b4b05 SHA512 cbc180d9ed895c19519e8fd891dc3487b89ce90f139cc8f7bfeebd1d563740254d963ea38e588f05e42f86901eadfefab9f37040d2798bb15ac4ba7f3d693b81 WHIRLPOOL 1bd3219a4816be8a093d047f3605a175a9fee6f7d9dc9ee4648fb31ea5e9709b415d36813aa1d83327aa2ec4a8d14ce8e8acceed4b5752ca712a4f2dda709728
+DIST navi2ch-1.8.4.tar.gz 470499 SHA256 a2647881d1c20539148f8a01fcfa6f230d59582331ffd2d930effcbba307c603 SHA512 3028ea05c1e264f734f5a7578a0eb7e7aa5f23dbe33ccf9b0659344dbbb36c140842100923bb77e82614307e9793fb73e2bff42d6308438410d80102e33a3184 WHIRLPOOL 66b73d26e4b161d65a3720f6d16aca576c3ac9a7585d6bffd9e1e29d4082ed750f83ea625bad87fa6ef81265103514c13b7c031965ab22d309cdd5c482ff52f4
diff --git a/app-emacs/navi2ch/files/50navi2ch-gentoo.el b/app-emacs/navi2ch/files/50navi2ch-gentoo.el
new file mode 100644
index 000000000000..512b80d45248
--- /dev/null
+++ b/app-emacs/navi2ch/files/50navi2ch-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'navi2ch "navi2ch" "Navigator for 2ch for Emacs." t)
diff --git a/app-emacs/navi2ch/metadata.xml b/app-emacs/navi2ch/metadata.xml
new file mode 100644
index 000000000000..7751814d02a5
--- /dev/null
+++ b/app-emacs/navi2ch/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cjk</herd>
+<herd>emacs</herd>
+<upstream>
+ <remote-id type="sourceforge">navi2ch</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/navi2ch/navi2ch-1.8.3-r1.ebuild b/app-emacs/navi2ch/navi2ch-1.8.3-r1.ebuild
new file mode 100644
index 000000000000..5961018b720f
--- /dev/null
+++ b/app-emacs/navi2ch/navi2ch-1.8.3-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit elisp
+
+DESCRIPTION="A navigator for the Japanese textboard 2ch"
+HOMEPAGE="http://navi2ch.sourceforge.net/"
+SRC_URI="mirror://sourceforge/navi2ch/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ econf \
+ --with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
+ --with-icondir="${EPREFIX}${SITEETC}/${PN}"
+}
+
+# This is NOT redundant, elisp.eclass redefines src_compile
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ elisp-install ${PN} contrib/*.el || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ dodoc ChangeLog* NEWS README TODO || die
+ newdoc contrib/README README.contrib || die
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog
+ elog "Please add to your ~/.emacs"
+ elog "If you use mona-font,"
+ elog "\t(setq navi2ch-mona-enable t)"
+ elog "If you use izonmoji-mode,"
+ elog "\t(require 'izonmoji-mode)"
+ elog "\t(add-hook 'navi2ch-bm-mode-hook 'izonmoji-mode-on)"
+ elog "\t(add-hook 'navi2ch-article-mode-hook 'izonmoji-mode-on)"
+ elog "\t(add-hook 'navi2ch-popup-article-mode-hook 'izonmoji-mode-on)"
+ elog
+}
diff --git a/app-emacs/navi2ch/navi2ch-1.8.4.ebuild b/app-emacs/navi2ch/navi2ch-1.8.4.ebuild
new file mode 100644
index 000000000000..5961018b720f
--- /dev/null
+++ b/app-emacs/navi2ch/navi2ch-1.8.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit elisp
+
+DESCRIPTION="A navigator for the Japanese textboard 2ch"
+HOMEPAGE="http://navi2ch.sourceforge.net/"
+SRC_URI="mirror://sourceforge/navi2ch/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ econf \
+ --with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
+ --with-icondir="${EPREFIX}${SITEETC}/${PN}"
+}
+
+# This is NOT redundant, elisp.eclass redefines src_compile
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ elisp-install ${PN} contrib/*.el || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ dodoc ChangeLog* NEWS README TODO || die
+ newdoc contrib/README README.contrib || die
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog
+ elog "Please add to your ~/.emacs"
+ elog "If you use mona-font,"
+ elog "\t(setq navi2ch-mona-enable t)"
+ elog "If you use izonmoji-mode,"
+ elog "\t(require 'izonmoji-mode)"
+ elog "\t(add-hook 'navi2ch-bm-mode-hook 'izonmoji-mode-on)"
+ elog "\t(add-hook 'navi2ch-article-mode-hook 'izonmoji-mode-on)"
+ elog "\t(add-hook 'navi2ch-popup-article-mode-hook 'izonmoji-mode-on)"
+ elog
+}