summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/vim-core/vim-core-9999.ebuild')
-rw-r--r--app-editors/vim-core/vim-core-9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-editors/vim-core/vim-core-9999.ebuild b/app-editors/vim-core/vim-core-9999.ebuild
index 49bba1db86db..3c18feca9036 100644
--- a/app-editors/vim-core/vim-core-9999.ebuild
+++ b/app-editors/vim-core/vim-core-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
VIM_VERSION="8.1"
-inherit estack vim-doc flag-o-matic bash-completion-r1 prefix
+inherit estack vim-doc flag-o-matic bash-completion-r1 prefix desktop
if [[ ${PV} == 9999* ]] ; then
inherit git-r3
@@ -201,6 +201,9 @@ src_install() {
fi
newbashcomp "${FILESDIR}"/xxd-completion xxd
+
+ # install gvim icon since both vim/gvim desktop files reference it
+ doicon -s scalable "${FILESDIR}"/gvim.svg
}
pkg_postinst() {