summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/alien/alien-8.90.ebuild')
-rw-r--r--app-arch/alien/alien-8.90.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-arch/alien/alien-8.90.ebuild b/app-arch/alien/alien-8.90.ebuild
new file mode 100644
index 000000000000..05808dfb9920
--- /dev/null
+++ b/app-arch/alien/alien-8.90.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="Converts between the rpm, dpkg, stampede slp, and slackware tgz file formats"
+HOMEPAGE="http://kitenet.net/programs/alien"
+SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc ~ppc64 x86"
+IUSE="+bzip2"
+
+RDEPEND="app-arch/rpm
+ app-arch/dpkg
+ bzip2? ( app-arch/bzip2 )
+ dev-util/debhelper
+ >=app-arch/tar-1.14.91"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -e s%'$(VARPREFIX)'%${D}% -e s%'$(PREFIX)'%${D}/usr%g \
+ -i "${S}"/Makefile.PL || die "sed failed."
+}