summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-portage/elt-patches/Manifest1
-rw-r--r--app-portage/elt-patches/elt-patches-20241121.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-portage/elt-patches/Manifest b/app-portage/elt-patches/Manifest
index cab89598f0bc..25f00971a1ce 100644
--- a/app-portage/elt-patches/Manifest
+++ b/app-portage/elt-patches/Manifest
@@ -2,3 +2,4 @@ DIST elt-patches-20240512.tar.xz 46176 BLAKE2B 8ca496aae63dd49e7148b7c06e687b364
DIST elt-patches-20240721.tar.xz 46392 BLAKE2B 87d2cefebcacbfa447e8981bf16eda3d21bcf4190e91c478280cd81089ab43440a86ff84a5c6b2cda7d772707dad645d4f481d9ec2543f9c14059fe084c2f54d SHA512 a8a8f55e5e1b0a2ea67895e86307a6fd5116593c25a2e3cc6fb2361f21eddc125a91c46ef84c0fd036c1bb25a682a4ff07c581c041a9b853d713d5c8f73d8d5b
DIST elt-patches-20240824.tar.xz 47256 BLAKE2B 3fc40af8eb219277a11051be3e8391bed08fba28a7d79b83ee3ab3cf6360d5d0c04ce2a2db7d627eaf76e029899cafb1ad22ac465634a17d3ba6b7b48d9a457d SHA512 0eb502b026003e918e8aa4045cb3556524d52c331c099a445b9638b3cdfdabf22538c08a0526332671c3623db77bf56d3b6f580402abbc5253d1dca9ec759476
DIST elt-patches-20240912.tar.xz 47436 BLAKE2B 589643e96f83a13fec4553c4ceb14af5993be43e3519678ecfcbd689d7a0016d2cd3c06f131548c90da19188a75cd2828accc5bd516373fa64401bdbad92bce2 SHA512 502347387c594df9ebb453c5258d0d8125694b6170da6136d9579d1535e6d944f9b4eda1a049cdadbb1df29665c00165c1b0f0804413ac4470a082c49272bebd
+DIST elt-patches-20241121.tar.xz 47760 BLAKE2B e0ac30748586dc5885539d79f29d5283f80cea51fdbd4af44640b7475f6a46d5c4bc30e4b452a495c3bde16d103f5e320667969c30f06cf55824b2fcdab1e45f SHA512 bce7fc40f10f8db568a3a7237daa3ce9e23dd9ea3c41f26e285cdc350c0b7afbd44eed996324ea9b091b7e69990822458e09c486f12deb70b1a5ee917aa43a80
diff --git a/app-portage/elt-patches/elt-patches-20241121.ebuild b/app-portage/elt-patches/elt-patches-20241121.ebuild
new file mode 100644
index 000000000000..3f398a3135ba
--- /dev/null
+++ b/app-portage/elt-patches/elt-patches-20241121.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Collection of patches for libtool.eclass"
+HOMEPAGE="https://gitweb.gentoo.org/proj/elt-patches.git/"
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="
+ https://anongit.gentoo.org/git/proj/elt-patches.git
+ https://github.com/gentoo/elt-patches
+ "
+ inherit git-r3
+else
+ SRC_URI="
+ https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.xz
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz
+ "
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~arm64-linux ~ppc64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+# The 'check' target currently wants network access to fetch libtool tarballs.
+RESTRICT="test"
+
+RDEPEND="sys-apps/gentoo-functions"
+BDEPEND="app-arch/xz-utils"
+
+src_compile() {
+ emake rootprefix="${EPREFIX}" libdirname="$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" rootprefix="${EPREFIX}" install
+}