summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/actionmailer/Manifest2
-rw-r--r--dev-ruby/actionmailer/actionmailer-6.1.7.2.ebuild46
-rw-r--r--dev-ruby/actionmailer/actionmailer-6.1.7.3.ebuild46
3 files changed, 0 insertions, 94 deletions
diff --git a/dev-ruby/actionmailer/Manifest b/dev-ruby/actionmailer/Manifest
index 014320437f0e..c93033a73cf8 100644
--- a/dev-ruby/actionmailer/Manifest
+++ b/dev-ruby/actionmailer/Manifest
@@ -1,5 +1,3 @@
-DIST rails-6.1.7.2.tgz 11037081 BLAKE2B 0004f4bc8b2370119cbe0f6a9133278ae78b1d274f040f08d18edd06696e6fcc609154a042c68b77e11893fbef83ec8eabd9f1e2c28920269189ee1352a0695a SHA512 f667904b0d3ffda3579e5046da3b36c242581bacf140966bf1dc59fc7ea91f34f4affc76b0d6cfad4b80f0332aeec5fc8ab35fb793fc935f1d1b4fe6d18ce1de
-DIST rails-6.1.7.3.tgz 11038169 BLAKE2B 7e379b9ae3b63cb78638c1e0817ff40dc8aad79ba76b6d82310fbb4d6f5ef3dab4f252de9e49766143b828bfbce2ef7c9db3f108b5406708b61a83aeda47ea74 SHA512 fb84516a6cf370109bf45f2162161d23f375d7dc10249ed10200c74ec402129b07ac0e59bcde98a74eb499769a0cdd937af691edaabe44e061262d5510adc02e
DIST rails-6.1.7.4.tgz 11038583 BLAKE2B 737044b6f92f2555fd9374e0b0fef7e26e53e2ac2103f1e3d89124929416aeda1295adfa7493471472c6ff0fbb057dea0bd9c184bbb45ae572185b98c399177f SHA512 caa7e2a79f747befb5f6f17adec1cc43530dbb35741775b2ebdcf59476efecd277dad025073a4b519a35754367cca04290c24bb8d8ae4235fda696ead531a94f
DIST rails-7.0.5.1.tgz 11077848 BLAKE2B 17dc2527b762d242c1cc141b5480c0917c8eafb53c55d3034d5af272e9be5760f6c3e16ce1a60041f11af4f99da23e79ff46e9f9fe88412932f2524bf057c478 SHA512 5053ed666cede0bfeb7a534f248538406a1bf5afe0d5ee9e285b4eeb3158566fdd665c7a20012833e6927e7dbb3d881361a5d7f8ce7e326f8e3faf5d571da3e7
DIST rails-7.0.6.tgz 11090672 BLAKE2B 87d3c1d37f0af4c6a9590d9e38cf1674c59b01b1e15d9883e4d303935b13c48cf9a53d9b3db63490a515b035ba500c6db9b938c329ee82f3adf9eb5897a69fe7 SHA512 93d91d25117e01460d3bd9bdd21743d19f377487a4cd2d0cd22f4d9deba524451033c83f52515270ff823b6c26306fe30be8c360bb527c59a789c04dd5fc1dac
diff --git a/dev-ruby/actionmailer/actionmailer-6.1.7.2.ebuild b/dev-ruby/actionmailer/actionmailer-6.1.7.2.ebuild
deleted file mode 100644
index fd3ed9d165b5..000000000000
--- a/dev-ruby/actionmailer/actionmailer-6.1.7.2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="Framework for designing email-service layers"
-HOMEPAGE="https://github.com/rails/rails"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/actionpack-${PV}
- ~dev-ruby/actionview-${PV}
- ~dev-ruby/activejob-${PV}
- >=dev-ruby/mail-2.5.4:* =dev-ruby/mail-2*:*
- dev-ruby/rails-dom-testing:2"
-
-ruby_add_bdepend "test? (
- dev-ruby/mocha
-)"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
- rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
- sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
-
- # Avoid a test failing only on attachment ordering, since this is a
- # security release.
- sed -i -e '/adding inline attachments while rendering mail works/askip "gentoo: fails on ordering"' test/base_test.rb || die
-}
diff --git a/dev-ruby/actionmailer/actionmailer-6.1.7.3.ebuild b/dev-ruby/actionmailer/actionmailer-6.1.7.3.ebuild
deleted file mode 100644
index fd3ed9d165b5..000000000000
--- a/dev-ruby/actionmailer/actionmailer-6.1.7.3.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="Framework for designing email-service layers"
-HOMEPAGE="https://github.com/rails/rails"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/actionpack-${PV}
- ~dev-ruby/actionview-${PV}
- ~dev-ruby/activejob-${PV}
- >=dev-ruby/mail-2.5.4:* =dev-ruby/mail-2*:*
- dev-ruby/rails-dom-testing:2"
-
-ruby_add_bdepend "test? (
- dev-ruby/mocha
-)"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
- rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
- sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
-
- # Avoid a test failing only on attachment ordering, since this is a
- # security release.
- sed -i -e '/adding inline attachments while rendering mail works/askip "gentoo: fails on ordering"' test/base_test.rb || die
-}