summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-23 08:42:38 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-23 08:53:09 +0200
commit9172bf722acb52d956e5f8fc525e5b672abdd50a (patch)
treea2125eee0a0ded5068ce762edec9764fc4b6b4a8 /xfce-extra
parentdev-python/pygame: Enable py3.12 (diff)
downloadgentoo-9172bf722acb52d956e5f8fc525e5b672abdd50a.tar.gz
gentoo-9172bf722acb52d956e5f8fc525e5b672abdd50a.tar.bz2
gentoo-9172bf722acb52d956e5f8fc525e5b672abdd50a.zip
xfce-extra/xfce4-cpugraph-plugin: Bump to 1.2.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.8.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-cpugraph-plugin/Manifest b/xfce-extra/xfce4-cpugraph-plugin/Manifest
index a7fe8a59906d..db1941c8dde3 100644
--- a/xfce-extra/xfce4-cpugraph-plugin/Manifest
+++ b/xfce-extra/xfce4-cpugraph-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-cpugraph-plugin-1.2.7.tar.bz2 438674 BLAKE2B d4ca7c850410aeaad7d5eb0156c4feea4a01a0be0d77a62c0165ead9158d2c7e41220ca8ca38e82db69600991f5578f85c1793d1bc94954e9f9cb85cb147316a SHA512 a89f5d9f986717a78a2cbd31db378c1b220cabfc83bf1c85f2533ecccd17b4ed70a3de9321f2e06fcbca2b77d3b02e5a8541e2adf936567a426e1d7221faaa3b
+DIST xfce4-cpugraph-plugin-1.2.8.tar.bz2 465181 BLAKE2B 68e8ee6ee8e943480626716f493d70046b8eeafbc9597d233e887009111fa5e6401fa652b0830163d413bfa7f28d004a75985cc72601e2b8cac7048dfd773e8b SHA512 f0f4201d0572997e8c610a25fcb957ebe4dd224204421aeba4e8ca54da71bdd97fa147dd7af7097b9e09ce6e1317836622a0bcbfec9589858010942993e27940
diff --git a/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.8.ebuild b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.8.ebuild
new file mode 100644
index 000000000000..894630719613
--- /dev/null
+++ b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A system load plug-in for the Xfce panel"
+HOMEPAGE="
+ https://goodies.xfce.org/projects/panel-plugins/xfce4-cpugraph-plugin
+ https://gitlab.xfce.org/panel-plugins/xfce4-cpugraph-plugin
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.50
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.16.0:=
+ >=xfce-base/libxfce4util-4.17.2:=
+ >=xfce-base/xfce4-panel-4.16.0:=
+ >=xfce-base/xfconf-4.12.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}