summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-18 12:55:50 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-18 13:23:23 +0200
commit34c4eb48e8bfcac0b1a44978fd789a43f00936e3 (patch)
treedfefb2ac425f89d93ce5096af75934729bcf4180 /xfce-base/xfconf
parentsys-apps/less: add 668 (diff)
downloadgentoo-34c4eb48e8bfcac0b1a44978fd789a43f00936e3.tar.gz
gentoo-34c4eb48e8bfcac0b1a44978fd789a43f00936e3.tar.bz2
gentoo-34c4eb48e8bfcac0b1a44978fd789a43f00936e3.zip
xfce-base/xfconf: Bump to 4.19.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/xfconf')
-rw-r--r--xfce-base/xfconf/Manifest1
-rw-r--r--xfce-base/xfconf/xfconf-4.19.3.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/xfce-base/xfconf/Manifest b/xfce-base/xfconf/Manifest
index 83d00e98fc63..059d77968672 100644
--- a/xfce-base/xfconf/Manifest
+++ b/xfce-base/xfconf/Manifest
@@ -1,2 +1,3 @@
DIST xfconf-4.18.3.tar.bz2 648479 BLAKE2B 021198bba84c651f05cf47a1034617e088dcce6502eac6f0f160f8000e2309bac5f44b57cc0a4156f907a25002cc3c539ab0c16fc5b3018bbc8ae9a58b212133 SHA512 e1aa133f79ea584af067369f6fd059cd444c4743270ed90a8b0dfe158f7ae6fbc78af62fab67c64674060c2fd1404f06602ac8c019b0db8b70779a17fde4a327
DIST xfconf-4.19.2.tar.bz2 764445 BLAKE2B d8deed120a8f6b901c544edff48f5748d5d0959cba886a817dc61cefca3cf169d7d557f2ac23c7167f0d294d8cee649d391041250a5475315f9b81e55be5de4c SHA512 fc72592013c2d9375ca66b917585506083e05d60325ced3b2c00877404b4c188ca028c7a213f50a2bf88ec8590864200f32c7fb56df2993baa233abbc1871673
+DIST xfconf-4.19.3.tar.bz2 778192 BLAKE2B e8467ffe199ba990cb7f8fa6c1d6aa5dc57f2b4ea0e48849696f8dd14c9abfa2ffc86dcec08cc576ccceff8db63f8966f0f6c1d0b72ccab5b987aafbbdd1e4ef SHA512 483245d0a9ccf5396c4c24e57b581c8eef7fd9390cf069cdc2effeb432ad05f641648402e0445d407eb824b683bf7ecd0b589554fdf5db5bd668de2e80fe9d49
diff --git a/xfce-base/xfconf/xfconf-4.19.3.ebuild b/xfce-base/xfconf/xfconf-4.19.3.ebuild
new file mode 100644
index 000000000000..a2c9f5c21a6b
--- /dev/null
+++ b/xfce-base/xfconf/xfconf-4.19.3.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 vala
+
+DESCRIPTION="A configuration management system for Xfce"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/xfconf/start
+ https://gitlab.xfce.org/xfce/xfconf/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="debug +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+DEPEND="
+ >=dev-libs/glib-2.72.0
+ sys-apps/dbus
+ >=xfce-base/libxfce4util-4.17.3:=
+ introspection? ( >=dev-libs/gobject-introspection-1.66:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable vala)
+ $(use_enable debug checks)
+ --with-bash-completion-dir="$(get_bashcompdir)"
+ )
+
+ use vala && vala_setup
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ local service_dir=${HOME}/.local/share/dbus-1/services
+ mkdir -p "${service_dir}" || die
+ cat > "${service_dir}/org.xfce.Xfconf.service" <<-EOF || die
+ [D-BUS Service]
+ Name=org.xfce.Xfconf
+ Exec=${S}/xfconfd/xfconfd
+ EOF
+
+ (
+ # start isolated dbus session bus
+ dbus_data=$(dbus-launch --sh-syntax) || exit
+ eval "${dbus_data}"
+
+ # -j>1 often hangs
+ # https://gitlab.xfce.org/xfce/xfconf/-/issues/13
+ nonfatal emake -j1 check
+ ret=${?}
+
+ kill "${DBUS_SESSION_BUS_PID}"
+ exit "${ret}"
+ ) || die
+}
+
+src_install() {
+ default
+ find "${D}" -type f -name '*.la' -delete || die
+}