summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/treewm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/treewm')
-rw-r--r--x11-wm/treewm/Manifest1
-rw-r--r--x11-wm/treewm/files/treewm-0.4.5-gcc43.patch20
-rw-r--r--x11-wm/treewm/metadata.xml12
-rw-r--r--x11-wm/treewm/treewm-0.4.5-r1.ebuild61
-rw-r--r--x11-wm/treewm/treewm-0.4.5.ebuild42
5 files changed, 136 insertions, 0 deletions
diff --git a/x11-wm/treewm/Manifest b/x11-wm/treewm/Manifest
new file mode 100644
index 000000000000..fe5600fc1434
--- /dev/null
+++ b/x11-wm/treewm/Manifest
@@ -0,0 +1 @@
+DIST treewm-0.4.5.tar.bz2 87098 SHA256 3daea1c8d5dfe44bfe4e038e112f7ae5044c7978b196acd0258ac6f51e2f8c13
diff --git a/x11-wm/treewm/files/treewm-0.4.5-gcc43.patch b/x11-wm/treewm/files/treewm-0.4.5-gcc43.patch
new file mode 100644
index 000000000000..a8faf4319871
--- /dev/null
+++ b/x11-wm/treewm/files/treewm-0.4.5-gcc43.patch
@@ -0,0 +1,20 @@
+--- treewm-0.4.5b/src/action.cc 2009-01-17 18:17:32.000000000 -0400
++++ treewm-0.4.5/src/action.cc 2009-01-17 18:20:41.000000000 -0400
+@@ -9,6 +9,7 @@
+ #include "clienttree.h"
+ #include "clientinfo.h"
+ #include <unistd.h>
++#include <string.h>
+
+ Action::Action(Section *section) {
+ s = section;
+--- treewm-0.4.5b/src/resmanager.h 2009-01-17 18:17:32.000000000 -0400
++++ treewm-0.4.5/src/resmanager.h 2009-01-17 18:21:10.000000000 -0400
+@@ -12,6 +12,7 @@
+ #include "global.h"
+ #include "client.h"
+ #include <map>
++#include <string.h>
+
+ struct ltstr {
+ bool operator() (const char* s1, const char* s2) const {
diff --git a/x11-wm/treewm/metadata.xml b/x11-wm/treewm/metadata.xml
new file mode 100644
index 000000000000..775c9627a346
--- /dev/null
+++ b/x11-wm/treewm/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>lordvan@gentoo.org</email>
+ <name>Thomas Raschbacher</name>
+ </maintainer>
+ <longdescription>WindowManager that arranges the windows in a tree not a list</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">treewm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-wm/treewm/treewm-0.4.5-r1.ebuild b/x11-wm/treewm/treewm-0.4.5-r1.ebuild
new file mode 100644
index 000000000000..2cc8b1d229a1
--- /dev/null
+++ b/x11-wm/treewm/treewm-0.4.5-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="WindowManager that arranges the windows in a tree (not in a list)"
+SRC_URI="mirror://sourceforge/treewm/${P}.tar.bz2"
+HOMEPAGE="http://treewm.sourceforge.net/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXxf86vm
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-misc/imake
+ x11-proto/xf86vidmodeproto"
+
+src_prepare() {
+ # bug 251845
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+ # bug 86453
+ sed -i xprop/dsimple.c \
+ -e 's:malloc:Malloc:g' \
+ || die "sed xprop/dsimple.c"
+}
+
+src_compile() {
+ # only compile treewm, not (x11-apps/){xprop,xkill}
+ emake treewm \
+ CXX=$(tc-getCXX) \
+ CCOPTIONS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}" \
+ PREFIX="/usr" ROOT="${D}" \
+ || die "emake"
+}
+
+src_install() {
+ # only install treewm, not (x11-apps/){xprop,xkill}
+ dobin src/treewm
+ dodoc AUTHORS ChangeLog PROBLEMS README README.tiling TODO default.cfg \
+ sample.cfg
+ insinto /usr/share/pixmaps/treewm
+ doins src/pixmaps/*.xpm
+}
+
+pkg_postinst() {
+ elog "x11-wm/treewm used to install its own versions of x11-apps/xprop and"
+ elog "x11-apps/xkill as treewm-xprop and treewm-xkill respectively, since"
+ elog "they are assumed to be broken in combination with treewm. Since"
+ elog "X(org) has become modular since treewm's last release and are not"
+ elog "installed by default, we can leave those out and simply point out"
+ elog "that it is NOT adviseable to use these programs when using treewm."
+}
diff --git a/x11-wm/treewm/treewm-0.4.5.ebuild b/x11-wm/treewm/treewm-0.4.5.ebuild
new file mode 100644
index 000000000000..d412bd23fa91
--- /dev/null
+++ b/x11-wm/treewm/treewm-0.4.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="WindowManager that arranges the windows in a tree (not in a list)"
+SRC_URI="mirror://sourceforge/treewm/${P}.tar.bz2"
+HOMEPAGE="http://treewm.sourceforge.net/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc ppc"
+IUSE=""
+
+RDEPEND="x11-libs/libXau
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXxf86vm
+ x11-libs/libXdmcp
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-misc/imake
+ x11-proto/xf86vidmodeproto"
+
+src_unpack() {
+ unpack ${A}
+ # bug 251845
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+ # bug 86453
+ sed -i -e "s:malloc:Malloc:g" "${S}"/xprop/dsimple.c
+}
+
+src_compile() {
+ emake PREFIX="/usr" ROOT="${D}" || die
+}
+
+src_install() {
+ make PREFIX="/usr" ROOT="${D}" install || die
+
+ # hack for Gentoo's doc policy:
+ cd "${D}/usr/share/doc/treewm" && dodoc * && cd .. && rm -rf treewm || die
+}