summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/aewm++/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/aewm++/files')
-rw-r--r--x11-wm/aewm++/files/aewm++-1.1.5-gcc43.patch36
-rw-r--r--x11-wm/aewm++/files/aewm++-1.1.5-makefile.patch34
2 files changed, 70 insertions, 0 deletions
diff --git a/x11-wm/aewm++/files/aewm++-1.1.5-gcc43.patch b/x11-wm/aewm++/files/aewm++-1.1.5-gcc43.patch
new file mode 100644
index 000000000000..23cacdc43a2b
--- /dev/null
+++ b/x11-wm/aewm++/files/aewm++-1.1.5-gcc43.patch
@@ -0,0 +1,36 @@
+diff -ur aewm++-1.1.5.orig/client.cc aewm++-1.1.5/client.cc
+--- aewm++-1.1.5.orig/client.cc 2005-05-23 06:06:01.000000000 +0300
++++ aewm++-1.1.5/client.cc 2008-05-03 23:50:02.000000000 +0300
+@@ -6,6 +6,8 @@
+ */
+ #include "aewm.hh"
+
++#include <string.h>
++
+ Client::Client(Display *d, Window new_client)
+ {
+ initialize(d);
+diff -ur aewm++-1.1.5.orig/main.cc aewm++-1.1.5/main.cc
+--- aewm++-1.1.5.orig/main.cc 2005-02-12 05:38:32.000000000 +0200
++++ aewm++-1.1.5/main.cc 2008-05-03 23:50:02.000000000 +0300
+@@ -6,6 +6,8 @@
+ */
+ #include "aewm.hh"
+
++#include <string.h>
++
+ // Dunno where I ripped this from. Kudos to the author whoever he is!
+ void forkExec(char *cmd)
+ {
+diff -ur aewm++-1.1.5.orig/windowmanager.cc aewm++-1.1.5/windowmanager.cc
+--- aewm++-1.1.5.orig/windowmanager.cc 2005-05-17 04:41:42.000000000 +0300
++++ aewm++-1.1.5/windowmanager.cc 2008-05-03 23:50:02.000000000 +0300
+@@ -6,6 +6,8 @@
+ */
+ #include "aewm.hh"
+
++#include <string.h>
++
+ WindowManager* wm;
+
+ #define AEWM_KEY_ALT_COUNT 4
diff --git a/x11-wm/aewm++/files/aewm++-1.1.5-makefile.patch b/x11-wm/aewm++/files/aewm++-1.1.5-makefile.patch
new file mode 100644
index 000000000000..8b84a9963469
--- /dev/null
+++ b/x11-wm/aewm++/files/aewm++-1.1.5-makefile.patch
@@ -0,0 +1,34 @@
+Respect CFLAGS, LDFLAGS, don't strip binaries
+
+http://bugs.gentoo.org/show_bug.cgi?id=336099
+
+--- aewm++-1.1.5/Makefile
++++ aewm++-1.1.5/Makefile
+@@ -1,9 +1,6 @@
+ CC = g++
+-ADDITIONAL_CFLAGS = -g -O2 -march=i686 -Wall
+
+ prefix = /usr
+-INCLUDES = -I$/usr/X11R6
+-LDPATH = -L/usr/X11R6/lib
+ LIBS = -lXext -lX11
+
+ # SHAPE = Shape Extension
+@@ -28,14 +25,13 @@
+ all: aewm++
+
+ aewm++: $(OBJS)
+- $(CC) $(OBJS) $(LDPATH) $(LIBS) -o $@
++ $(CXX) $(LDFLAGS) $(OBJS) $(LDPATH) $(LIBS) -o $@
+
+ $(OBJS): %.o: %.cc $(HEADERS)
+- $(CC) $(CFLAGS) $(ADDITIONAL_CFLAGS) $(DEFINES) $(INCLUDES) -c $< -o $@
++ $(CXX) $(CXXFLAGS) $(DEFINES) $(INCLUDES) -c $< -o $@
+
+ install: all
+- mkdir -p $(DESTDIR)$(prefix)/bin
+- install -s aewm++ $(DESTDIR)$(prefix)/bin
++ install -D -m 755 aewm++ $(DESTDIR)$(prefix)/bin/aewm++
+
+ clean:
+ rm -f aewm++ $(OBJS) core