summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2024-01-20 01:55:14 +0000
committerUlrich Müller <ulm@gentoo.org>2024-01-20 19:47:55 +0100
commit7abc320b443497e4b02822d52f420e42b8730050 (patch)
tree929205e97bf48cec214b4c80092a9950f09abb98 /x11-themes
parentdev-python/netifaces: Stabilize 0.11.0-r2 arm, #922570 (diff)
downloadgentoo-7abc320b443497e4b02822d52f420e42b8730050.tar.gz
gentoo-7abc320b443497e4b02822d52f420e42b8730050.tar.bz2
gentoo-7abc320b443497e4b02822d52f420e42b8730050.zip
x11-themes/mate-themes: Remove COPYING files
Clean up copying files which aren't needed as the user has already accepted this in package.license. Rewoked removed command based on ulm's suggestion. Closes: https://bugs.gentoo.org/599654 Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/mate-themes/mate-themes-3.22.24-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-themes/mate-themes/mate-themes-3.22.24-r1.ebuild b/x11-themes/mate-themes/mate-themes-3.22.24-r1.ebuild
new file mode 100644
index 000000000000..fa121bd8c466
--- /dev/null
+++ b/x11-themes/mate-themes/mate-themes-3.22.24-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools xdg
+
+MATE_GTK_V="$(ver_cut 1-2)"
+
+HOMEPAGE="https://mate-desktop.org"
+DESCRIPTION="A set of MATE themes, with sets for users with limited or low vision"
+SRC_URI="https://pub.mate-desktop.org/releases/themes/${MATE_GTK_V}/${P}.tar.xz"
+
+LICENSE="CC-BY-SA-3.0 GPL-3+ LGPL-2.1+ LGPL-3"
+SLOT="0/${MATE_GTK_V}"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+RESTRICT="binchecks strip"
+
+RDEPEND="
+ >=x11-libs/gdk-pixbuf-2:2
+ >=x11-libs/gtk+-2:2
+"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.19.8:*
+ >=dev-build/autoconf-2.53
+ >=x11-misc/icon-naming-utils-0.8.7:0
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ # Cleanup files from user's system as license is already accepted in package.licence
+ # the default install phase chokes if they're not available to install.
+ find "${ED}"/usr/share/themes -type f -name COPYING -delete || die
+}