summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2024-04-06 15:43:28 +0100
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-09 20:19:23 +0300
commitb64c4e8099242ebdb775ecc3ed3cb36404a4ffcc (patch)
tree78602a4608d729768d955c23f885eede3c2379aa /x11-terms
parentx11-terms/mate-terminal: drop 1.27.1 (diff)
downloadgentoo-b64c4e8099242ebdb775ecc3ed3cb36404a4ffcc.tar.gz
gentoo-b64c4e8099242ebdb775ecc3ed3cb36404a4ffcc.tar.bz2
gentoo-b64c4e8099242ebdb775ecc3ed3cb36404a4ffcc.zip
x11-terms/mate-terminal: add 1.28.1
Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/mate-terminal/Manifest1
-rw-r--r--x11-terms/mate-terminal/mate-terminal-1.28.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/x11-terms/mate-terminal/Manifest b/x11-terms/mate-terminal/Manifest
index 4c05e3d0aadf..149df2764a5b 100644
--- a/x11-terms/mate-terminal/Manifest
+++ b/x11-terms/mate-terminal/Manifest
@@ -1 +1,2 @@
DIST mate-terminal-1.26.1.tar.xz 2131524 BLAKE2B 72831d4a29ac8b1407c26337a966405a27b6742007624adaae51c973fe5bf44dee6259bf89f356b4b5023a9a535568050e79d22fdd911c05db3296476109a9e7 SHA512 75b40f58a117e10ae9214e11af3c00227a366ab8788fa4f06788c3be7173d402d6eba2b4f63fc9b0a6723311c0b79f912e02170650c5257adefe0f5ca0d78198
+DIST mate-terminal-1.28.1.tar.xz 2143744 BLAKE2B 9bf50305426758204782ffa8921accd506c5859a10dedef7ee4d74ea35560c5f6cebfbce64ee6c42c195d140af930bb133d38e354f67ff3a17121eff3fb9b7f7 SHA512 7606fb87bc8b8af97ac932bdc7f34aa86681e54cf03b9f7838d60a1d02925b2b56e0987fc1e9d26e41c512f208198e102215440c63d771f618fade2496024287
diff --git a/x11-terms/mate-terminal/mate-terminal-1.28.1.ebuild b/x11-terms/mate-terminal/mate-terminal-1.28.1.ebuild
new file mode 100644
index 000000000000..7e7071583457
--- /dev/null
+++ b/x11-terms/mate-terminal/mate-terminal-1.28.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="The MATE Terminal"
+LICENSE="FDL-1.1+ GPL-3+ LGPL-3+"
+SLOT="0"
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0
+ >=dev-libs/glib-2.50:2
+ >=gnome-base/dconf-0.13.4
+ x11-libs/gdk-pixbuf:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/pango
+ >=x11-libs/gtk+-3.22:3[X]
+ >=x11-libs/vte-0.48:2.91
+"
+
+RDEPEND="${COMMON_DEPEND}
+ >=mate-base/mate-desktop-1.6
+ virtual/libintl
+"
+
+BDEPEND="${COMMON_DEPEND}
+ app-text/rarian
+ app-text/yelp-tools
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"