summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2017-05-29 14:18:00 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2017-05-29 14:19:12 +0200
commit54dad47e478953c0eb8d892682aa39cf7039f500 (patch)
tree7af06217cfd4bc0fa165aaf6e10b1e1d8bc7b224 /x11-plugins
parentx11-plugins/wmmand: drop old (diff)
downloadgentoo-54dad47e478953c0eb8d892682aa39cf7039f500.tar.gz
gentoo-54dad47e478953c0eb8d892682aa39cf7039f500.tar.bz2
gentoo-54dad47e478953c0eb8d892682aa39cf7039f500.zip
x11-plugins/wmdrawer: decompress manpage, bug #619980
Also update EAPI Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmdrawer/wmdrawer-0.10.5-r3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-plugins/wmdrawer/wmdrawer-0.10.5-r3.ebuild b/x11-plugins/wmdrawer/wmdrawer-0.10.5-r3.ebuild
new file mode 100644
index 000000000000..b27b454cb214
--- /dev/null
+++ b/x11-plugins/wmdrawer/wmdrawer-0.10.5-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="dockapp which provides a drawer (retractable button bar) to launch applications"
+HOMEPAGE="http://people.easter-eggs.org/~valos/wmdrawer/"
+SRC_URI="http://people.easter-eggs.org/~valos/wmdrawer/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( README TODO AUTHORS ChangeLog wmdrawerrc.example )
+PATCHES=( "${FILESDIR}"/${P}-gtk+-2.patch )
+
+src_prepare() {
+ default
+
+ gunzip doc/wmdrawer.1x.gz || die
+
+ # Honour Gentoo CFLAGS
+ sed -i -e "s|-O3|${CFLAGS}|" Makefile || die
+ # Fix LDFLAGS ordering per bug #248640
+ sed -i -e 's/$(CC) $(LDFLAGS) -o $@ $(OBJS)/$(CC) -o $@ $(OBJS) $(LDFLAGS)/' Makefile || die
+ # Do not auto-strip binaries
+ sed -i -e 's/ strip $@//' Makefile || die
+ # Honour Gentoo LDFLAGS
+ sed -i -e 's/$(CC) -o/$(CC) $(REAL_LDFLAGS) -o/' Makefile || die
+}
+
+src_compile() {
+ emake REAL_LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin wmdrawer
+ doman doc/wmdrawer.1x
+ einstalldocs
+}