summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-11-07 03:40:30 -0500
committerEli Schwartz <eschwartz@gentoo.org>2024-11-08 00:08:58 -0500
commit386af8830065bef43155045cc7d3356ff21a0900 (patch)
tree8f542ebd7f729950b75796acb238455b17d7c303 /x11-plugins
parentdev-python/dulwich: Bump to 0.22.5 (diff)
downloadgentoo-386af8830065bef43155045cc7d3356ff21a0900.tar.gz
gentoo-386af8830065bef43155045cc7d3356ff21a0900.tar.bz2
gentoo-386af8830065bef43155045cc7d3356ff21a0900.zip
x11-plugins/wmbatteries: fix modern C porting in configure
Regenerate the configure script to take advantage of updates to core autoconf macros so that system probes function correctly. The software doesn't actually build with Modern C. That is tracked by a different bug. It's an open question whether this package makes sense to package anyway -- especially given it is only even *keyworded* for x86... Closes: https://bugs.gentoo.org/942786 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmbatteries/wmbatteries-0.1.3-r1.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/x11-plugins/wmbatteries/wmbatteries-0.1.3-r1.ebuild b/x11-plugins/wmbatteries/wmbatteries-0.1.3-r1.ebuild
index fe71b8cc9c04..d7e36b7ce091 100644
--- a/x11-plugins/wmbatteries/wmbatteries-0.1.3-r1.ebuild
+++ b/x11-plugins/wmbatteries/wmbatteries-0.1.3-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit autotools
+
DESCRIPTION="Dock app for monitoring the current battery status and CPU temperature"
HOMEPAGE="https://sourceforge.net/projects/wmbatteries"
SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.bz2"
@@ -19,3 +21,8 @@ DEPEND="${RDEPEND}
x11-base/xorg-proto"
DOCS=( AUTHORS THANKS README example/wmbatteriesrc )
+
+src_prepare() {
+ default
+ eautoreconf
+}