summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmfishtime
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmfishtime')
-rw-r--r--x11-plugins/wmfishtime/Manifest1
-rw-r--r--x11-plugins/wmfishtime/files/wmfishtime-1.24-gtk.patch60
-rw-r--r--x11-plugins/wmfishtime/files/wmfishtime-1.24-no_display.patch19
-rw-r--r--x11-plugins/wmfishtime/metadata.xml10
-rw-r--r--x11-plugins/wmfishtime/wmfishtime-1.24-r1.ebuild34
-rw-r--r--x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild38
6 files changed, 162 insertions, 0 deletions
diff --git a/x11-plugins/wmfishtime/Manifest b/x11-plugins/wmfishtime/Manifest
new file mode 100644
index 000000000000..3be14345f433
--- /dev/null
+++ b/x11-plugins/wmfishtime/Manifest
@@ -0,0 +1 @@
+DIST wmfishtime-1.24.tar.gz 21895 SHA256 7d92889d295558acd8af79f4d74c6fa7c980ac1010b7f0691249a117b34bba07 SHA512 7df3c6648b46c6f67cf094f634dc7699c1dd1ee4f4a18dbf63d74ebda74f322524b83d99f10a1c8c8c8a5040d78b071754a40ff162fdb13a5a00d01f1eb5c4e6 WHIRLPOOL df9c90ceb80e377f9ea58ef92df62970b97d7279c6a4a79b49d3f0162b900b303dd06e35065c0fd5ebf2744e7291d5ae37854bd5da8fe6c584225f30a66d2307
diff --git a/x11-plugins/wmfishtime/files/wmfishtime-1.24-gtk.patch b/x11-plugins/wmfishtime/files/wmfishtime-1.24-gtk.patch
new file mode 100644
index 000000000000..68d4c057c44e
--- /dev/null
+++ b/x11-plugins/wmfishtime/files/wmfishtime-1.24-gtk.patch
@@ -0,0 +1,60 @@
+diff -ur wmfishtime-1.24.orig/fishmon.c wmfishtime-1.24/fishmon.c
+--- wmfishtime-1.24.orig/fishmon.c 2004-05-13 02:55:59.000000000 +0300
++++ wmfishtime-1.24/fishmon.c 2008-01-12 16:19:34.000000000 +0200
+@@ -648,6 +648,7 @@
+
+ /* make a copy for the iconwin - parameters are the same */
+ memcpy(&attri, &attr, sizeof(GdkWindowAttr));
++ attri.window_type = GDK_WINDOW_CHILD;
+
+ sizehints.flags = USSize;
+ sizehints.width = 64;
+@@ -679,7 +680,6 @@
+ wmhints.window_group = win;
+ wmhints.flags =
+ StateHint | IconWindowHint | IconPositionHint | WindowGroupHint;
+- XSetWMHints(GDK_WINDOW_XDISPLAY(bm.win), win, &wmhints);
+
+ bm.gc = gdk_gc_new(bm.win);
+
+@@ -693,6 +693,8 @@
+
+ gdk_window_show(bm.win);
+
++ XSetWMHints(GDK_WINDOW_XDISPLAY(bm.win), win, &wmhints);
++
+ #undef MASK
+ } /* make_new_fishmon_dockapp */
+
+diff -ur wmfishtime-1.24.orig/Makefile wmfishtime-1.24/Makefile
+--- wmfishtime-1.24.orig/Makefile 2001-05-26 23:49:41.000000000 +0300
++++ wmfishtime-1.24/Makefile 2008-01-12 16:22:30.000000000 +0200
+@@ -2,11 +2,11 @@
+ DESTDIR =
+
+ # where to install this program
+-PREFIX = $(DESTDIR)/usr/X11R6
++PREFIX = $(DESTDIR)/usr
+
+ # no user serviceable parts below this line
+ # optimization cflags
+-CFLAGS = -O3 -Wall `gtk-config --cflags` ${EXTRA}
++CFLAGS += -Wall `pkg-config gtk+-2.0 --cflags` ${EXTRA}
+ # profiling cflags
+ # CFLAGS=-ansi -pedantic -Wall -pg -O3 `gtk-config --cflags` ${EXTRA} -DPRO
+ # test coverage cflags
+@@ -16,7 +16,7 @@
+ CC = gcc
+ SHELL = sh
+ OBJS = fishmon.o
+-LIBS = `gtk-config --libs | sed "s/-lgtk//g"`
++LIBS = `pkg-config gtk+-2.0 --libs` -lm -lX11
+ INSTALL = -m 755
+
+ all: wmfishtime
+@@ -30,4 +30,4 @@
+ # You're going to have to be root to do this!
+ install:
+ install $(INSTALL) wmfishtime $(PREFIX)/bin
+- install $(INSTALL) wmfishtime.1 $(PREFIX)/man/man1
++ install $(INSTALL) wmfishtime.1 $(PREFIX)/share/man/man1
diff --git a/x11-plugins/wmfishtime/files/wmfishtime-1.24-no_display.patch b/x11-plugins/wmfishtime/files/wmfishtime-1.24-no_display.patch
new file mode 100644
index 000000000000..a991cdab934b
--- /dev/null
+++ b/x11-plugins/wmfishtime/files/wmfishtime-1.24-no_display.patch
@@ -0,0 +1,19 @@
+--- fishmon.c.orig 2010-06-27 18:38:42.000000000 +0200
++++ fishmon.c 2010-06-27 18:40:56.000000000 +0200
+@@ -152,6 +152,8 @@
+
+ int main(int argc, char **argv)
+ {
++ /* This is needed to proper dockapp work on >=GTK+-2.18 */
++ setenv("GDK_NATIVE_WINDOWS", "1", 0);
+ int ch;
+ GdkEvent *event;
+ #ifdef PRO
+@@ -694,6 +696,7 @@
+ gdk_window_show(bm.win);
+
+ XSetWMHints(GDK_WINDOW_XDISPLAY(bm.win), win, &wmhints);
++ gdk_window_show(bm.iconwin);
+
+ #undef MASK
+ } /* make_new_fishmon_dockapp */
diff --git a/x11-plugins/wmfishtime/metadata.xml b/x11-plugins/wmfishtime/metadata.xml
new file mode 100644
index 000000000000..1c3407201408
--- /dev/null
+++ b/x11-plugins/wmfishtime/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+<longdescription>
+WMFishTime is a silly little dockapp that displays current time, date, and day
+of the week. It features alpha-blended bubbles, anti-aliased clock hands, and
+fish swimming behind the clock face.
+</longdescription>
+</pkgmetadata>
diff --git a/x11-plugins/wmfishtime/wmfishtime-1.24-r1.ebuild b/x11-plugins/wmfishtime/wmfishtime-1.24-r1.ebuild
new file mode 100644
index 000000000000..3dec9d0db116
--- /dev/null
+++ b/x11-plugins/wmfishtime/wmfishtime-1.24-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A fun clock applet for your desktop featuring swimming fish"
+HOMEPAGE="http://www.ne.jp/asahi/linux/timecop"
+SRC_URI="http://www.ne.jp/asahi/linux/timecop/software/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gtk.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc ALL_I_GET_IS_A_GRAY_BOX AUTHORS ChangeLog CODING README
+}
diff --git a/x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild b/x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild
new file mode 100644
index 000000000000..b373fb396389
--- /dev/null
+++ b/x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A fun clock applet for your desktop featuring swimming fish"
+HOMEPAGE="http://www.ne.jp/asahi/linux/timecop"
+SRC_URI="http://www.ne.jp/asahi/linux/timecop/software/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gtk.patch \
+ "${FILESDIR}"/${P}-no_display.patch
+
+ sed -i -e "s/\$(CC)/& \$(LDFLAGS)/" Makefile || die #331891
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc ALL_I_GET_IS_A_GRAY_BOX AUTHORS ChangeLog CODING README
+}