summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schuerch <nativemad@gentoo.org>2024-02-25 12:35:41 +0100
committerAndreas Schuerch <nativemad@gentoo.org>2024-02-25 12:37:24 +0100
commit2dc060c1f907e35648bacaafd25e6221ddd90bc9 (patch)
tree6d3ac773f923f4592cb728084a8b78e18bfee164 /x11-plugins/pidgin-libnotify
parentx11-plugins/pidgin-mbpurple: add myself as a maintainer (diff)
downloadgentoo-2dc060c1f907e35648bacaafd25e6221ddd90bc9.tar.gz
gentoo-2dc060c1f907e35648bacaafd25e6221ddd90bc9.tar.bz2
gentoo-2dc060c1f907e35648bacaafd25e6221ddd90bc9.zip
x11-plugins/pidgin-libnotify: EAPI8 bump, fix LICENSE
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Andreas Schuerch <nativemad@gentoo.org>
Diffstat (limited to 'x11-plugins/pidgin-libnotify')
-rw-r--r--x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14-r2.ebuild b/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14-r2.ebuild
new file mode 100644
index 000000000000..355ebc642121
--- /dev/null
+++ b/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Pidgin-libnotify provides popups for pidgin via a libnotify interface"
+HOMEPAGE="https://gaim-libnotify.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gaim-libnotify/${P}.tar.gz
+ mirror://debian/pool/main/p/${PN}/${PN}_${PV}-4.debian.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+IUSE="nls debug"
+
+RDEPEND=">=x11-libs/libnotify-0.3.2
+ net-im/pidgin[gtk]
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${WORKDIR}/debian/patches"
+ "${FILESDIR}/${P}-libnotify-0.7.patch"
+)
+
+src_prepare() {
+ default
+ sed -i -e '/CFLAGS/s:-g3::' configure || die "sed failed"
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die "Pruning failed"
+}