summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-30 05:15:47 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-30 06:48:12 -0400
commite08f9c22c1b49251a14d47fec27378ca60f5a6c4 (patch)
treead4424d0398cfa2cac2287e8df3fdae558441911 /x11-misc
parentx11-misc/xearth: force gcc -E for imake's generation (diff)
downloadgentoo-e08f9c22c1b49251a14d47fec27378ca60f5a6c4.tar.gz
gentoo-e08f9c22c1b49251a14d47fec27378ca60f5a6c4.tar.bz2
gentoo-e08f9c22c1b49251a14d47fec27378ca60f5a6c4.zip
x11-misc/xfishtank: force gcc -E for imake's generation
Requires traditional cpp support and is broken in all sort of ways with clang-cpp / -E. Can still use clang & friends for everything else. Ideally these packages need to be built another way or last rited, imake will just accumulate more problems. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xfishtank/xfishtank-2.5.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/x11-misc/xfishtank/xfishtank-2.5.ebuild b/x11-misc/xfishtank/xfishtank-2.5.ebuild
index c8e58903ac86..48df2a9e84c5 100644
--- a/x11-misc/xfishtank/xfishtank-2.5.ebuild
+++ b/x11-misc/xfishtank/xfishtank-2.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,16 +18,19 @@ RDEPEND="
x11-libs/libXext
x11-libs/libXt
"
-DEPEND="${RDEPEND}"
-BDEPEND="
+DEPEND="
+ ${RDEPEND}
x11-base/xorg-proto
+"
+BDEPEND="
+ sys-devel/gcc
>=x11-misc/imake-1.0.8-r1
"
S=${WORKDIR}/${PN}
src_configure() {
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die
+ IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die
}
src_compile() {