summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2022-04-06 22:41:52 +0200
committerSebastian Pipping <sping@gentoo.org>2022-04-06 22:43:47 +0200
commitbd348c2ca05bc5201e5fc40e5b358ab04e522e31 (patch)
tree2357e1c22022684c84db927fb75c2fe616c9eec5 /x11-misc
parentnet-misc/dropbear: add 2022.82 (diff)
downloadgentoo-bd348c2ca05bc5201e5fc40e5b358ab04e522e31.tar.gz
gentoo-bd348c2ca05bc5201e5fc40e5b358ab04e522e31.tar.bz2
gentoo-bd348c2ca05bc5201e5fc40e5b358ab04e522e31.zip
x11-misc/spnavcfg: Make 1.0 compile without qtchooser installed
Closes: https://bugs.gentoo.org/836948 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.30, Repoman-3.0.3
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/spnavcfg/spnavcfg-1.0.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/x11-misc/spnavcfg/spnavcfg-1.0.ebuild b/x11-misc/spnavcfg/spnavcfg-1.0.ebuild
index f2b2fbed5906..d49c3125f96a 100644
--- a/x11-misc/spnavcfg/spnavcfg-1.0.ebuild
+++ b/x11-misc/spnavcfg/spnavcfg-1.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit toolchain-funcs
+inherit toolchain-funcs qmake-utils
DESCRIPTION="GTK-based GUI to configure a space navigator device"
HOMEPAGE="http://spacenav.sourceforge.net/"
@@ -29,5 +29,11 @@ src_configure() {
}
src_compile() {
- emake CC="$(tc-getCC)"
+ local args=(
+ CC="$(tc-getCC)"
+ MOC="$(qt5_get_bindir)/moc"
+ RCC="$(qt5_get_bindir)/rcc"
+ UIC="$(qt5_get_bindir)/uic"
+ )
+ emake "${args[@]}"
}