summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2025-01-13 20:52:17 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2025-01-13 20:52:30 +0100
commit81e7c01822c02ba9d8bc01a70d6ecd92dad5e838 (patch)
tree1365f901a6747c46813f60670b6bf17a5ffe4dc1 /x11-misc
parentnet-misc/lldpd: add 1.0.19 (diff)
downloadgentoo-81e7c01822c02ba9d8bc01a70d6ecd92dad5e838.tar.gz
gentoo-81e7c01822c02ba9d8bc01a70d6ecd92dad5e838.tar.bz2
gentoo-81e7c01822c02ba9d8bc01a70d6ecd92dad5e838.zip
x11-misc/zim: add 0.76.0
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/zim/Manifest1
-rw-r--r--x11-misc/zim/zim-0.76.0.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/x11-misc/zim/Manifest b/x11-misc/zim/Manifest
index 810472407ad9..9342ffc74391 100644
--- a/x11-misc/zim/Manifest
+++ b/x11-misc/zim/Manifest
@@ -1 +1,2 @@
DIST zim-0.75.2.tar.gz 3257345 BLAKE2B 452716cbc6c149645c5146d8fcef2449c7c316ac57da9870dbe26b9fec13b6827a6368295277dc3b2b7a7874a7c930da27612a8e8e00b295ae9ecb3942d0e65b SHA512 ea6f361047690dfb314a3510d34880a4831d142c94fc0ca08e1c29869fd42d5fd1182c47edc241edeb512fed601a474af6d9970f819e8a8b67135c7589ae461a
+DIST zim-0.76.0.tar.gz 3363266 BLAKE2B 36a34965ede3f544926bba515e66fdf6e1fbb211ecba96eaf9778f3e52cc6bacee5f03c91aadf0c4290f27b96e93fae450c3563c78be443e12aee84a5e0c65cb SHA512 f8504d936db7335a7f31c011b710e785ee58d2c9321e12dbd15848a4326ac24df7bc8069c4d2c8d07c2f537a694d9cf48be7acd36ab8a60b9ba35b4f3e094f8e
diff --git a/x11-misc/zim/zim-0.76.0.ebuild b/x11-misc/zim/zim-0.76.0.ebuild
new file mode 100644
index 000000000000..bc5254db5c21
--- /dev/null
+++ b/x11-misc/zim/zim-0.76.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..13} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_SINGLE_IMPL=1
+VIRTUALX_REQUIRED=test
+inherit distutils-r1 optfeature virtualx xdg
+
+DESCRIPTION="A desktop wiki"
+HOMEPAGE="
+ https://zim-wiki.org/
+ https://github.com/zim-desktop-wiki/zim-desktop-wiki
+"
+SRC_URI="https://github.com/${PN}-desktop-wiki/${PN}-desktop-wiki/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+S=${WORKDIR}/${PN}-desktop-wiki-${PV/_/-}
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')
+ x11-libs/gtk+:3[introspection]
+ x11-misc/xdg-utils
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md PLUGIN_WRITING.md README.md )
+PATCHES=( "${FILESDIR}"/${PN}-0.60-remove-ubuntu-theme.patch )
+
+python_prepare_all() {
+ if [[ ${LINGUAS} ]]; then
+ local lingua
+ for lingua in translations/*.po; do
+ lingua=${lingua/.po}
+ lingua=${lingua/translations\/}
+ has ${lingua} ${LINGUAS} || \
+ { rm translations/${lingua}.po || die; }
+ done
+ fi
+
+ distutils-r1_python_prepare_all
+ export XDG_RUNTIME_DIR=fakethis
+}
+
+python_compile() {
+ sed -e "s#./build#${BUILD_DIR}/build#" -i setup.py || die
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ if has_version dev-vcs/git; then
+ git config --global user.email "git@example.com" || die
+ git config --global user.name "GitExample" || die
+ fi
+
+ virtx ./test.py
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ insinto /usr/share/icons
+ doins -r xdg/hicolor
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "Spell checker" app-text/gtkspell[introspection]
+ optfeature "GNU R Plot Editor" dev-lang/R
+ optfeature "Version control Bazaar support" dev-vcs/breezy
+ optfeature "Diagram Editor" media-gfx/graphviz
+ optfeature "Insert Screenshot" "media-gfx/imagemagick media-gfx/scrot"
+ optfeature "Score Editor" media-sound/lilypond
+ optfeature "Gnuplot Editor" sci-visualization/gnuplot
+ optfeature "Equation Editor" virtual/latex-base app-text/dvipng
+}