summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-04-14 09:07:09 -0400
committerJoonas Niilola <juippis@gentoo.org>2021-04-15 09:38:57 +0300
commit90061e9a748419f7a3e2e23ca9e10623c294a938 (patch)
treeee2be1f0e1ff2339d90bfda7e254aae214fb5d6e /x11-misc/xsnap
parentx11-misc/xkeycaps: fix build with -native-symlinks (diff)
downloadgentoo-90061e9a748419f7a3e2e23ca9e10623c294a938.tar.gz
gentoo-90061e9a748419f7a3e2e23ca9e10623c294a938.tar.bz2
gentoo-90061e9a748419f7a3e2e23ca9e10623c294a938.zip
x11-misc/xsnap: fix build with -native-symlinks
Removed no longer necessary sed for toolchain vars and swapped DEPEND with BDEPEND to put imake in the right block Closes: https://bugs.gentoo.org/726242 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-misc/xsnap')
-rw-r--r--x11-misc/xsnap/xsnap-1.5.15-r2.ebuild25
1 files changed, 11 insertions, 14 deletions
diff --git a/x11-misc/xsnap/xsnap-1.5.15-r2.ebuild b/x11-misc/xsnap/xsnap-1.5.15-r2.ebuild
index e28502a5b0ca..dd43dcab6432 100644
--- a/x11-misc/xsnap/xsnap-1.5.15-r2.ebuild
+++ b/x11-misc/xsnap/xsnap-1.5.15-r2.ebuild
@@ -24,12 +24,12 @@ RDEPEND="
${COMMON_DEPEND}
media-fonts/font-misc-misc
"
-DEPEND="
- ${COMMON_DEPEND}
+DEPEND="${COMMON_DEPEND}"
+BDEPEND="
app-text/rman
dev-lang/perl
x11-base/xorg-proto
- x11-misc/imake
+ >=x11-misc/imake-1.0.8-r1
"
DOCS=( AUTHORS Changelog README )
PATCHES=( "${FILESDIR}"/${P}-root_name.patch )
@@ -46,21 +46,18 @@ src_prepare() {
sed -i \
-e '/^LOCALEDIR=/d' \
po/Makefile || die
+}
- xmkmf || die
-
- sed -i \
- -e '/ CC = /d' \
- -e '/ LD = /d' \
- -e '/ CDEBUGFLAGS = /d' \
- -e '/ CCOPTIONS = /d' \
- -e 's|CPP = cpp|CPP = $(CC)|g' \
- Makefile || die
+src_configure() {
+ CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
+ IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die
}
src_compile() {
- tc-export CC
- emake CCOPTIONS="${CFLAGS}" EXTRA_LDOPTIONS="${LDFLAGS}"
+ emake \
+ CC="$(tc-getCC)" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}"
}
src_install() {