summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-11 23:57:30 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-12 13:21:20 +0200
commit5dd1f7a3908dec9ae6cf6773acd8ec3b33fc0b2c (patch)
treeaa65ec817aedf64ac5a125d764476541093d1811 /x11-misc/synergy/files
parentdev-ros/moveit_msgs: bump to 0.10.0 (diff)
downloadgentoo-5dd1f7a3908dec9ae6cf6773acd8ec3b33fc0b2c.tar.gz
gentoo-5dd1f7a3908dec9ae6cf6773acd8ec3b33fc0b2c.tar.bz2
gentoo-5dd1f7a3908dec9ae6cf6773acd8ec3b33fc0b2c.zip
x11-misc/synergy: 1.9.1 version bump, Qt4 -> Qt5
Bug: https://bugs.gentoo.org/649572 Bug: https://bugs.gentoo.org/653468 Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'x11-misc/synergy/files')
-rw-r--r--x11-misc/synergy/files/synergy-1.9.1-cmake-version.patch57
-rw-r--r--x11-misc/synergy/files/synergy-1.9.1-gtest.patch28
-rw-r--r--x11-misc/synergy/files/synergy-1.9.1-internal-gmock-gtest.patch23
-rw-r--r--x11-misc/synergy/files/synergy-1.9.1-pthread.patch11
-rw-r--r--x11-misc/synergy/files/synergy-1.9.1-qt-5.11.patch31
5 files changed, 150 insertions, 0 deletions
diff --git a/x11-misc/synergy/files/synergy-1.9.1-cmake-version.patch b/x11-misc/synergy/files/synergy-1.9.1-cmake-version.patch
new file mode 100644
index 000000000000..da7a603119d3
--- /dev/null
+++ b/x11-misc/synergy/files/synergy-1.9.1-cmake-version.patch
@@ -0,0 +1,57 @@
+--- a/cmake/Version.cmake 2018-04-10 12:18:42.000000000 +0200
++++ b/cmake/Version.cmake 2018-05-11 23:29:24.499906356 +0200
+@@ -23,7 +23,7 @@
+ if (DEFINED ENV{SYNERGY_VERSION_PATCH})
+ set (SYNERGY_VERSION_PATCH $ENV{SYNERGY_VERSION_PATCH})
+ else()
+- set (SYNERGY_VERSION_PATCH 0)
++ set (SYNERGY_VERSION_PATCH 1)
+ message (WARNING "Synergy version wasn't set. Set to ${SYNERGY_VERSION_MAJOR}.${SYNERGY_VERSION_MINOR}.${SYNERGY_VERSION_PATCH}")
+ endif()
+ endif()
+@@ -36,29 +36,6 @@
+ endif()
+ endif()
+
+-if (NOT DEFINED SYNERGY_REVISION)
+- if (DEFINED ENV{GIT_COMMIT})
+- string (SUBSTRING $ENV{GIT_COMMIT} 0 8 SYNERGY_REVISION)
+- elseif (SYNERGY_VERSION_STAGE STREQUAL "snapshot")
+- execute_process (
+- COMMAND git rev-parse --short=8 HEAD
+- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
+- OUTPUT_VARIABLE SYNERGY_REVISION
+- OUTPUT_STRIP_TRAILING_WHITESPACE
+- )
+- endif()
+-endif()
+-
+-if (DEFINED SYNERGY_REVISION)
+- string(LENGTH ${SYNERGY_REVISION} SYNERGY_REVISION_LENGTH)
+- if (NOT ((SYNERGY_REVISION MATCHES "^[a-f0-9]+") AND (SYNERGY_REVISION_LENGTH EQUAL "8")))
+- message (FATAL_ERROR "SYNERGY_REVISION ('${SYNERGY_REVISION}') should be a short commit hash")
+- endif()
+- unset (SYNERGY_REVISION_LENGTH)
+-else()
+- set (SYNERGY_REVISION "0badc0de")
+-endif()
+-
+ if (DEFINED ENV{BUILD_NUMBER})
+ set (SYNERGY_BUILD_NUMBER $ENV{BUILD_NUMBER})
+ else()
+@@ -66,7 +43,6 @@
+ endif()
+
+ string (TIMESTAMP SYNERGY_BUILD_DATE "%Y%m%d" UTC)
+-set (SYNERGY_SNAPSHOT_INFO ".${SYNERGY_VERSION_STAGE}.${SYNERGY_REVISION}")
+
+ if (SYNERGY_VERSION_STAGE STREQUAL "snapshot")
+ set (SYNERGY_VERSION_TAG "${SYNERGY_VERSION_STAGE}.b${SYNERGY_BUILD_NUMBER}-${SYNERGY_REVISION}")
+@@ -80,7 +56,6 @@
+
+ add_definitions (-DSYNERGY_VERSION="${SYNERGY_VERSION}")
+ add_definitions (-DSYNERGY_VERSION_STRING="${SYNERGY_VERSION_STRING}")
+-add_definitions (-DSYNERGY_REVISION="${SYNERGY_REVISION}")
+ add_definitions (-DSYNERGY_BUILD_DATE="${SYNERGY_BUILD_DATE}")
+ add_definitions (-DSYNERGY_BUILD_NUMBER=${SYNERGY_BUILD_NUMBER})
+
diff --git a/x11-misc/synergy/files/synergy-1.9.1-gtest.patch b/x11-misc/synergy/files/synergy-1.9.1-gtest.patch
new file mode 100644
index 000000000000..f7a5e614e810
--- /dev/null
+++ b/x11-misc/synergy/files/synergy-1.9.1-gtest.patch
@@ -0,0 +1,28 @@
+--- a/src/lib/synergy/KeyMap.h
++++ b/src/lib/synergy/KeyMap.h
+@@ -24,7 +24,9 @@
+ #include "common/stdset.h"
+ #include "common/stdvector.h"
+
++#if WITH_GENTOO_TEST
+ #include <gtest/gtest_prod.h>
++#endif
+
+ namespace synergy {
+
+@@ -327,6 +329,7 @@
+ //@}
+
+
++#if WITH_GENTOO_TEST
+ private:
+ FRIEND_TEST(KeyMapTests,
+ findBestKey_requiredDown_matchExactFirstItem);
+@@ -341,6 +344,7 @@
+ FRIEND_TEST(KeyMapTests,
+ findBestKey_onlyOneRequiredDown_matchTwoRequiredChangesItem);
+ FRIEND_TEST(KeyMapTests, findBestKey_noRequiredDown_cannotMatch);
++#endif
+
+ private:
+ //! Ways to synthesize a key
diff --git a/x11-misc/synergy/files/synergy-1.9.1-internal-gmock-gtest.patch b/x11-misc/synergy/files/synergy-1.9.1-internal-gmock-gtest.patch
new file mode 100644
index 000000000000..bc8a96130575
--- /dev/null
+++ b/x11-misc/synergy/files/synergy-1.9.1-internal-gmock-gtest.patch
@@ -0,0 +1,23 @@
+--- a/src/test/CMakeLists.txt
++++ b/src/test/CMakeLists.txt
+@@ -14,20 +14,5 @@
+ # You should have received a copy of the GNU General Public License
+ # along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+-include_directories(
+- ../../ext/gtest
+- ../../ext/gtest/include
+- ../../ext/gmock
+- ../../ext/gmock/include)
+-
+-add_library(gtest STATIC ../../ext/gtest/src/gtest-all.cc)
+-add_library(gmock STATIC ../../ext/gmock/src/gmock-all.cc)
+-
+-if (UNIX)
+- # ignore warnings in gtest and gmock
+- set_target_properties(gtest PROPERTIES COMPILE_FLAGS "-w")
+- set_target_properties(gmock PROPERTIES COMPILE_FLAGS "-w")
+-endif()
+-
+ add_subdirectory(integtests)
+ add_subdirectory(unittests)
diff --git a/x11-misc/synergy/files/synergy-1.9.1-pthread.patch b/x11-misc/synergy/files/synergy-1.9.1-pthread.patch
new file mode 100644
index 000000000000..46ae6e1588b8
--- /dev/null
+++ b/x11-misc/synergy/files/synergy-1.9.1-pthread.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -141,6 +141,8 @@
+ check_library_exists ("pthread" pthread_create "" HAVE_PTHREAD)
+ if (HAVE_PTHREAD)
+ list (APPEND libs pthread)
++ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pthread")
++ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pthread")
+ else()
+ message (FATAL_ERROR "Missing library: pthread")
+ endif()
diff --git a/x11-misc/synergy/files/synergy-1.9.1-qt-5.11.patch b/x11-misc/synergy/files/synergy-1.9.1-qt-5.11.patch
new file mode 100644
index 000000000000..7a706a084d0b
--- /dev/null
+++ b/x11-misc/synergy/files/synergy-1.9.1-qt-5.11.patch
@@ -0,0 +1,31 @@
+--- a/src/gui/CMakeLists.txt 2018-05-11 23:30:26.425509147 +0200
++++ b/src/gui/CMakeLists.txt 2018-05-11 23:31:53.237354182 +0200
+@@ -39,7 +39,7 @@
+ target_link_libraries (synergy dns_sd)
+ endif()
+
+-qt5_use_modules (synergy Core Widgets Network)
++target_link_libraries (synergy Qt5::Core Qt5::Widgets Qt5::Network)
+ target_compile_definitions (synergy PRIVATE -DSYNERGY_VERSION_STAGE="${SYNERGY_VERSION_STAGE}")
+ target_compile_definitions (synergy PRIVATE -DSYNERGY_REVISION="${SYNERGY_REVISION}")
+
+--- a/src/gui/src/ActionDialog.cpp 2018-04-10 12:18:42.000000000 +0200
++++ b/src/gui/src/ActionDialog.cpp 2018-05-11 23:33:50.814498692 +0200
+@@ -25,6 +25,7 @@
+
+ #include <QtCore>
+ #include <QtGui>
++#include <QButtonGroup>
+
+ ActionDialog::ActionDialog(QWidget* parent, ServerConfig& config, Hotkey& hotkey, Action& action) :
+ QDialog(parent, Qt::WindowTitleHint | Qt::WindowSystemMenuHint),
+--- a/src/gui/src/ScreenSetupView.cpp 2018-04-10 12:18:42.000000000 +0200
++++ b/src/gui/src/ScreenSetupView.cpp 2018-05-11 23:35:33.304496343 +0200
+@@ -22,6 +22,7 @@
+
+ #include <QtCore>
+ #include <QtGui>
++#include <QHeaderView>
+
+ ScreenSetupView::ScreenSetupView(QWidget* parent) :
+ QTableView(parent)