summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2022-12-04 17:05:41 +0100
committerSebastian Pipping <sping@gentoo.org>2022-12-04 17:06:24 +0100
commit63cecf35be27d134b26b1fe5bca6d1644270c4ec (patch)
tree61c2da8d5f647aed7955cd9ca7e971ea70f8ec77 /x11-misc/safeeyes
parentapp-cdr/cdrdao: keyword 1.2.4-r1 for ~loong (diff)
downloadgentoo-63cecf35be27d134b26b1fe5bca6d1644270c4ec.tar.gz
gentoo-63cecf35be27d134b26b1fe5bca6d1644270c4ec.tar.bz2
gentoo-63cecf35be27d134b26b1fe5bca6d1644270c4ec.zip
x11-misc/safeeyes: Stop installing shipped stray .pyc files
Closes: https://bugs.gentoo.org/864765 Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'x11-misc/safeeyes')
-rw-r--r--x11-misc/safeeyes/safeeyes-2.1.4-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/x11-misc/safeeyes/safeeyes-2.1.4-r1.ebuild b/x11-misc/safeeyes/safeeyes-2.1.4-r1.ebuild
new file mode 100644
index 000000000000..18d803a78ba0
--- /dev/null
+++ b/x11-misc/safeeyes/safeeyes-2.1.4-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="tk" # for site-packages/Xlib/ext/randr.py
+
+inherit xdg distutils-r1
+
+DESCRIPTION="Linux alternative to EyeLeo"
+HOMEPAGE="https://github.com/slgobinath/SafeEyes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libappindicator:3[introspection]
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/croniter[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ media-sound/alsa-utils
+ x11-apps/xprop
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-misc/xprintidle
+ "
+
+DOCS=(
+ README.md
+)
+
+src_prepare() {
+ default
+ find . -type f -name \*.pyc -delete # bug #864765
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}