summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-02-27 16:29:14 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-02-27 16:31:03 +0100
commit834e62a9e5a36262c50f68d3ecdd78df3ac7a1fa (patch)
treea3d6464e19adfd25eb9951a1458e08cf5400ba5b /x11-misc/projecteur
parentdev-python/aiohttp: stable 3.7.4 for hppa/sparc, bug #772932 (diff)
downloadgentoo-834e62a9e5a36262c50f68d3ecdd78df3ac7a1fa.tar.gz
gentoo-834e62a9e5a36262c50f68d3ecdd78df3ac7a1fa.tar.bz2
gentoo-834e62a9e5a36262c50f68d3ecdd78df3ac7a1fa.zip
x11-misc/projecteur: bump to version 0.9.1
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'x11-misc/projecteur')
-rw-r--r--x11-misc/projecteur/Manifest1
-rw-r--r--x11-misc/projecteur/files/projecteur-0.9.1-dont-compress-manpage.patch27
-rw-r--r--x11-misc/projecteur/projecteur-0.9.1.ebuild53
3 files changed, 81 insertions, 0 deletions
diff --git a/x11-misc/projecteur/Manifest b/x11-misc/projecteur/Manifest
index e2af8f9c8b6a..2f6e18330cab 100644
--- a/x11-misc/projecteur/Manifest
+++ b/x11-misc/projecteur/Manifest
@@ -1 +1,2 @@
DIST projecteur-0.8.tar.gz 379203 BLAKE2B b2171bd6120c9f6245c129519e33adbb4661ea4cd0df5f30c6c90fbefb8b7c5024da5c6d920d4e162b818bc0fc6417731dcf0c540103ed6f12976123c45c69eb SHA512 e892e87f442cfa7f0102efa01b43e63ed7ea9c30c875496dd3d683ee769de66f0a4ccfae149f060924e5613dfd7758a0b19d565232fb6db75b9228cee4a956de
+DIST projecteur-0.9.1.tar.gz 392308 BLAKE2B 31ec19b81b9f3cf8c60712a52d3cf4dd96a215115d2fffc437892f276b9f1e6a58cf0c2165226166f0c2067f6ab2180829c8bc8204dbe368facbeef398da837f SHA512 28e0030a481dd2adb9eaba54066f060b61f7e4477918f46e25fad1e1a1c841dd5500c24779d66d3fab643e5aa39f92b0dd0c2fd7a0b80b8de8f258ae7572ed36
diff --git a/x11-misc/projecteur/files/projecteur-0.9.1-dont-compress-manpage.patch b/x11-misc/projecteur/files/projecteur-0.9.1-dont-compress-manpage.patch
new file mode 100644
index 000000000000..e7c96648e0c7
--- /dev/null
+++ b/x11-misc/projecteur/files/projecteur-0.9.1-dont-compress-manpage.patch
@@ -0,0 +1,27 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -223,14 +223,7 @@
+
+ # Configure man page and gzip it.
+ configure_file("${TMPLDIR}/projecteur.1" "projecteur.1" @ONLY)
+-find_program(GZIP_EXECUTABLE gzip)
+-add_custom_command(
+- OUTPUT ${OUTDIR}/projecteur.1.gz
+- COMMAND ${GZIP_EXECUTABLE} -9f -n "${OUTDIR}/projecteur.1"
+- WORKING_DIRECTORY ${OUTDIR}
+-)
+-add_custom_target(gzip-manpage ALL DEPENDS "${OUTDIR}/projecteur.1.gz")
+-install(FILES "${OUTDIR}/projecteur.1.gz" DESTINATION share/man/man1/)
++install(FILES "${OUTDIR}/projecteur.1" DESTINATION share/man/man1/)
+
+ configure_file("${TMPLDIR}/projecteur.metainfo.xml" "projecteur.metainfo.xml" @ONLY)
+ install(FILES "${OUTDIR}/projecteur.metainfo.xml" DESTINATION share/metainfo/)
+@@ -270,7 +263,7 @@
+ # PREINST_SCRIPT "${OUTDIR}/pkg/scripts/preinst"
+ POSTINST_SCRIPT "${OUTDIR}/pkg/scripts/postinst"
+ )
+- add_dependencies(dist-package gzip-manpage projecteur)
++ add_dependencies(dist-package projecteur)
+
+ # Additional files for debian packages, adhering to some debian rules,
+ # see https://manpages.debian.org/buster/lintian/lintian.1.en.html
diff --git a/x11-misc/projecteur/projecteur-0.9.1.ebuild b/x11-misc/projecteur/projecteur-0.9.1.ebuild
new file mode 100644
index 000000000000..6a27eb2c8109
--- /dev/null
+++ b/x11-misc/projecteur/projecteur-0.9.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/p/P}"
+
+inherit cmake udev xdg-utils
+
+DESCRIPTION="Linux Desktop Application for the Logitech Spotlight device"
+HOMEPAGE="https://github.com/jahnf/Projecteur"
+SRC_URI="https://github.com/jahnf/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ || (
+ dev-qt/qtgui:5[X(-)]
+ dev-qt/qtgui:5[xcb(-)]
+ )
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ virtual/udev
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-0.9.1-dont-compress-manpage.patch" )
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Don't treat all warnings as errors
+ sed -e '/add_compile_options/d' -i CMakeLists.txt || die
+}
+
+pkg_postinst() {
+ udev_reload
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ udev_reload
+ xdg_icon_cache_update
+}